Skip Navigation

[Resolved] Error message with Event calendar

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 14:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Jamaica (GMT-05:00)

This topic contains 14 replies, has 2 voices.

Last updated by leilaG 5 months ago.

Assigned support staff: Shane.

Author
Posts
#2415403
event-form-error.png

Hello,

We use the event calendar plugin and have a form for adding new events. It was working, but now it showing a toolset error.

Notice: Undefined property: stdClass::$ID in /nas/content/live/wapgstag/wp-content/plugins/toolset-blocks/vendor/toolset/toolset-theme-settings/compatibility-modules/controllers/toolset-theme-integration-settings-front-end-controller.php on line 79

#2415659

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Leila,

Thank you for getting in touch.

Have you tried temporarily disabling all the non-toolset plugins except the Events Calendar plugin and checking if the issue still remains ?

If it does please let me know and provide admin access to the site as well so that I can have a more detailed look for you.

Thanks,
Shane

#2417167

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Leila,

I've setup a test site at the link below to see if we can replicate.

Can you try to replicate the issue here on the test site so that we can see if it is something replicable on a fresh site.

hidden link

Thanks,
Shane

#2417555

Hi Shane,

We have the staging site already set you for you to use, with everything installed.
hidden link

Are you not able to use this?

Thanks
Leila

#2417615

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Leila,

The staging site can be used. However we need to ensure that this is something that is replicable on a fresh install and this is what I want to investigate before diving deeper into the staging site that you have.

This is the main reason for wanting to replicate it on the test site here. If its not replicable on the test site then it would mean that there is more at hand than a simple plugin conflict.

Please let me know if this is possible for you to do.

Thanks,
Shane

#2418095

Okay, how can I replicate the error on the test site without setting up everything again? installing plugins, creating pages etc. ?

#2418269

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Leila,

Given that the issue is with Toolset and the Events Calendar plugin i've already installed the required plugins.

What I'm trying to do is to figure how you've added the event calendar's add new event form on the frontend cause the shortcode below isn't working.
[tribe_community_events view="submission_form"]

If you can provide some clarity on how you achieved this, please let me know.
Thanks,
Shane

#2419827

Hi Shane,

We are using plugins:
The Events Calendar PRO
The Events Calendar: Community Events (For event submissions)

Let me know if you need anything else.

Thanks
Leila

#2419891

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Leila,

I've managed to replicate the issue. The problem only appears whenever the Avada theme is active. If a different theme is used then the issue doesn't appear.

I've escalated this to our second tier supporters for further checks.

Thanks,
Shane

#2423057

Thanks for the update, I'll wait to hear back.

#2444371

Hello, is there any update on this one?

#2444443

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Leila,

Unfortunately there hasn't been any development on this one as yet.

Given that it is a notice that is being displayed the form should still work as per usual. Additionally using the default page to add the events doesn't generate this error "site.com/events/community/add "

Apart from this there hasn't been any updates.

Thanks,
Shane

#2445025

Thanks for the suggestion Shane. The problem is, we can not easily add our own text to the top of this page - hidden link
Which is why we made this one - hidden link

#2448139

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Leila,

I understand the concern. However do you have your wordpress debug enabled ? If you do then you can workaround the issue by disabling the wordpress debugging so that the message isn't dumped onto the page.

As mentioned the issue is logged into our systems for our team to look at but I cannot give a timeline as to when this specific issue will be looked at since we don't work with unlimited developer resources and the developers determine what to prioritise.

Thanks,
Shane

#2448893

That worked. Thanks for the workaround Shane!