[Closed] Error installing Layouts, "are you sure you want to do that?"

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 7 replies, has 2 voices, and was last updated by  Noman 6 months, 1 week ago. The support staff assigned to this topic is Noman.

Viewing 8 posts - 1 through 8 (of 8 total)

I am trying to install Layouts plugin onto my site but every time I go about it I get that same error message. Then I tried to install the plugin manually and it would crash the site (white screen of death) each time.

I have read every forum and support post I can about this and tried each suggestion but still cannot get the plugin to work. Please help!


Thank you for your speedy reply


Forum moderator

Supporter languages: English (English )

Supporter Timezone: Asia/Karachi (GMT+05:00)

Hi Darren,

Thank you for contacting Toolset support. Please provide screenshot of the error which is displaying during installation.

1. Your site’s current WP memory is 256MB, please added these lines in wp-config.php file to increase it:

define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

2. Please also try to check it by deactivating all third-party plugins (except Toolset) and switching back to the Default Theme (e.g. Twenty Sixteen theme) to see for any possible conflicts with any of the plugins or themes?

Thank you


Okay, I've done all of the items you mentioned and am still having the same issue. White screen of death. What now? If I can't get this working I'm not sure I will want to keep this plugin and will need a refund. But that isn't the option I want to use, I do like the other aspects of the plugin and would like to get this working.


Any ideas?


Forum moderator

Supporter languages: English (English )

Supporter Timezone: Asia/Karachi (GMT+05:00)

Hello Darren,

I apologize for the inconvenience and I really want to solve this issue. I am not able to reproduce this issue at my end. Layouts plugin is not causing white screen of death.

1. Which version of Layouts plugin you are trying to install? Can you please give a try to install beta version 2.1-b5 of Layouts plugin and check that it resolves the issue:

2. Please Enable WordPress debugging in your site and look for any errors on the site while running update process or in error_log file: https://toolset.com/documentation/user-guides/debugging-toolset/

More infos about this process is available here:

3. Please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and check the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you


I have been trying to install the latest version (beta) like you mentioned as well as the previous version but have had the same issue with both.

I cannot give you access to my site since it is only a localhost site right now, I am only trying to learn how to use Toolset and haven't added it to any actual sites I own yet.

I can install the plugin using the regular upload method inside of the WP dashboard but then once I activate it the site will not load, just the white screen. The URL I get is: hidden link

The only way I can get my site back online is to change the plugin file name in /wp-content/plugins

The debug log is this:

[12-Oct-2017 08:34:01 UTC] WP_Community_Events::maybe_log_events_response: Valid response received. Details: {"api_url":"https:\/\/api.wordpress.org\/events\/1.0\/","request_args":{"body":{"number":5,"ip":"::","locale":"en_US","timezone":"America\/Denver"}},"response_code":200,"response_body":{"location":{"ip":""},"events":"5 events trimmed."}}


Forum moderator

Supporter languages: English (English )

Supporter Timezone: Asia/Karachi (GMT+05:00)

Hello Darren,

Can you please add following code in your wp-config.php file and check if any error displayed on screen Or in in debug.log file.

 // Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
// Enable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', true );
@ini_set( 'display_errors', 1 );
// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

Please provide Duplicator package of your site so that we can import that package and reproduce the issue. Use this plugin: https://wordpress.org/plugins/duplicator/

I have enabled private message box as well, looking forward to help you. Thank you

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘[Closed] Error installing Layouts, "are you sure you want to do that?"’ is closed to new replies.