Skip Navigation

[Closed] Edit Layout loading unnecessarily

This support ticket is created 2 years, 1 month ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

This topic contains 8 replies, has 2 voices.

Last updated by Minesh 2 years, 1 month ago.

Assigned support staff: Minesh.

Author
Posts
#1871719

lsS
Screenshot 2020-12-10 191633.jpg
Screenshot 2020-12-10 191502.jpg

I am trying to: create a new post or copy an older one and edit it to turn it into a new one, on my WordPress based website

Link to a page where the issue can be seen: hidden link

I expected to see: use my regular post editor (either a WordPress editor or another editor with another plugin)

Instead, I got: "Edit Layout" window by Toolset. The layout editor keeps on adding unnecessary layouts automatically and so not allow me to shift to my other editor. It does not even allow me to delete the auto-saved layouts.
I am facing this issue since the recent update by Toolset has been installed 2 days ago. I had a discussion about this issue with the WordPress support team. After trying testing, they suspect that the issue is due to a recent JQuery update by Toolset. If you need any other information you can refer them to WP dev site here: hidden link .

Please send me the solution to fix this problem. Without getting a solution for this issue, I am not able to post any new posts on my site.

Thank you.
Aparna
for TROP ICSU
hidden link

#1872787

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

First of all - After checking to debug the information you shared with us, I found that you are using outdated Toolset plugins. We always recommend running your site with the latest stable release plugin version.

*** Please make a FULL BACKUP of your database and website.***
Could you please update ALL Toolset plugins to it's latest officially released version. You can download the latest plugin release from your accounts page: (You can find views and Layouts plugin on Legacy plugins tab)
=> https://toolset.com/account/downloads/

Once you update All Toolset plugins, do you still see the issue, If yes:
- Do you see any JavaScript error on your browser's console?
- In order to minimise the cause of the issue - Could you please try to resolve your issue by deactivating all third-party plugins as well as the default theme to check for any possible conflicts with any of the plugins or themes?

#1873215

lsS
Screenshot 2020-12-11 193615.jpg

hi there

Thank you for replying. But my issue is not yet resolved.

As mentioned in my first email, actually this problem has been seen since I installed the latest updates by Toolset, and was not there before that! I have installed all the latest updates by Toolset. Have a look at the attached image.

To answer your Q:

- Do you see any JavaScript error on your browser's console?
Ans: No

- In order to minimise the cause of the issue - Could you please try to resolve your issue by deactivating all third-party plugins as well as the default theme to check for any possible conflicts with any of the plugins or themes?

Ans: If I deactivate my other plugin then my site pages get affected and so i can not keep it deactivated.
When i try to create a new post then every time i do not want to use any layout by Toolset. But the layout editor loads unnecessarily and keeps on autosaving and even i can't delete the autosaved versions!

Can you help?
Thank you.

#1875317

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

As per the screenshot you shared, you are still using the outdated Layouts and Views plugin version.

The current version of Layouts plugin is: 2.6.7
=> https://toolset.com/download/toolset-layouts/#changelog

The latest version of Views plugin is: 3.3.4
=> https://toolset.com/download/toolset-views/#changelog

You can download the latest version of those plugins from the following URL:
=> https://toolset.com/account/downloads/#legacy-plugins

And when I say deactivate the third-party plugin, I'm not asking you to deactivate it permanently but what I'm asking is to deactivate the third-party plugins one by one and check the issue and see what plugin is cause of possible conflict.

Do you see it working after updating ALL Toolset plugins to latest version? OR do you able to locate any possible plugin conflict?

When i try to create a new post then every time i do not want to use any layout by Toolset. But the layout editor loads unnecessarily and keeps on autosaving and even i can't delete the autosaved versions!
==>
Can you please share exact steps I will follow that should allow me to see this issue on your install and share temporary admin access details.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I have set the next reply to private which means only you and I have access to it.

#1877205

lsS
Screenshot 2020-12-15 220333.jpg

Hi there
Thank you for your reply.

I am afraid that it would be difficult for me to grant you temporary access to my website as ours is a global project and not all the involved bodies could find it comfortable for that.
The WP site we have is developed using the WP Business plan using wordpress.com.
So, if in the WP admin a plugin shows a flag that an update is available to download, I go for it. But if a plugin does not show an update then I can't download it.
I can now see that the Layout and Views plugins are flashing on my dashboard suddenly, which were not available two days ago!
Let me check the result of installing the latest updates of these plugins.
Let me also check if at all a temp access to you is absolutely necessary then what max can be done from my side.
Regards.

#1877227

lsS
Screenshot 2020-12-15 221806.jpg

Hi
I installed the latest updates for the Toolset Layout and Views plugins. Then I tried to create a new post. But the problem persists!
Pl find the attached screenshot. It shows how the layout editor gets loaded unnecessarily and does not go away even if the option of "Don't use a Layout" is clicked! You will find this option in the top right corner of the image.

So the problem is not yet solved!! Can you pl help?
Thanks.

#1878175

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Jamal is on Vacation. This is Minesh here and I'll take care of this ticket. Hope this is OK.

Can you please share access details so that I can see whats going wrong with your setup.

Basically, you are trying to create new post for default post type post and you dont want to assign Layouts to that post - correct?

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I have set the next reply to private which means only you and I have access to it.

#1883891

lsS

Hi Minesh

Thank you for your reply.
As mentioned in one of the earlier replies, I am afraid that it would be difficult for me to grant you temporary access to my website. Ours is a global project and not all the involved bodies could find it comfortable for giving you access to the site.

As you said, the problem is: when I am trying to create a new post for the default post type post I don't want to assign Layouts to that post. But even if I switch off the Layouts option, the Layout editor keeps on loading and does not allow me to do anything else!
As of now, I have no option but to deactivate the "Toolset Layout" so that I can create my posts without hindrance.

I am sure you could suggest to me some good solutions to overcome this problem of unwanted loading of the Toolset Layout Editor. Thanks.

#1883943

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

What I can do is I can offer you my test site where all latest Toolset plugins installed including Toolset Layouts:
=> hidden link

User: demo
pwd: Admin@999

Can you please dive into it and show me the problem? You can create test post/page whatever you want and how me the problem.

The topic ‘[Closed] Edit Layout loading unnecessarily’ is closed to new replies.