Skip Navigation

[Resolved] Document File Upload is coming to a 404 error when clicking the link.

This support ticket is created 3 years, 7 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by donaldM-2 3 years, 7 months ago.

Assigned support staff: Christian Cox.

Author
Posts
#1207862

I am using CRED form to upload a post type. It has a document file field and when i select the file and upload the file to the site, the url is not correct on the dashboard and returns a 404 error. Looking into the media library, it looks as if no file is even being uploaded. Is the files for the tooslet form being uploaded somewhere else?

#1207995

Hi, the files themselves should ultimately be uploaded in the /wp-content/uploads/ directory sorted into subdirectories by year and month. If the files are not being uploaded successfully, they may exist in your PHP temporary files directory, or they may not be uploaded anywhere on the server. It sounds like a conflict with another plugin or possibly a server configuration issue.

I see you have several other plugins active, including a content restriction plugin and some security plugins. Any of those could be causing a conflict, or there could be a server configuration issue preventing you from uploading specific types of files. First, I would try uploading the same file directly to the Media Library through wp-admin. If that works, then try the usual troubleshooting steps next:
- Temporarily activate a default theme like Twenty Nineteen and deactivate all plugins except Types, Views, and Forms.
- Test again. If the problem is resolved, reactivate your theme and other plugins one by one until the problem returns. Let me know what you find out.
- If the problem is not resolved, copy the invalid URL so I can see where the system thinks the file is stored.
- Turn on server logs so we can check to see if any backend errors are generated. If you're not familiar with server logs, I can show you how to activate them temporarily. Go in your wp-config.php file and look for

define('WP_DEBUG', false);

Change it to:

define('WP_DEBUG', true);

Then add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

Attempt to upload the document with Forms again. If any backend errors are thrown, this will create an error_log.txt file in your site's root directory. Please send me its contents. Once that is done, you can revert the changes you made to wp-config.php and delete the log file.

#1208004

My issue is resolved now. Thank you!