Skip Navigation

[Resolved] Custom role cannot preview pages (Access + WPML)

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Author
Posts
#1248261

I am trying to:
I have a custom role called "FR Editor". I have created a WPML Group for the French pages, and FR Editor role has all permissions selected.

I expected to see:
Users with FR Editor role should be able to preview any FR pages.

Instead, I got:
Users with FR Editor cannot preview drafts or pending FR pages. They can't see private FR pages either.
They can edit, publish, delete or view FR pages, but trying to preview them leads to a 404 / not found error.
They used to be able to preview pages or view private pages, I think this stopped working with the latest major upgrade (2.7).

NOTE: I have event tried the following (as a temporary workaround):
-> I have tried going to the Custom roles tab and adding the following global permissions to the role: edit_pages, publish_pages, read_private_pages
-> I have tried going to the Post types tab and adding the "Preview any" permission to the role under the Pages post type.
But none of this is working.

Thanks,

#1248521

Thanks for the report, I am escalating this to my 2nd tier support team for additional investigation. I'll let you know what I find out.

#1251849

Hi! Any progress on this?

Thanks!

#1252317

Hi, I'm still waiting on some feedback from our developers so I don't have a complete answer for you just yet. I'll let you know when I have some more concrete information.

#1302951

Hi!

Any news about this?

#1302957
#1302977

Hi, I can see that there has been work going on in this internal ticket as of last week. I don't have any concrete ETA just yet, but as soon as I know I'll update you here.

#1312355

Hi, our developers have let me know that this is scheduled to be fixed in Access 2.8, so I will keep you posted here as I receive more information about that delivery date.

#1347511

Hello, you can now find Access 2.8 available for immediate dowload at https://toolset.com/account/downloads, or for automatic update in wp-admin. Please update to the latest versions of all Toolset and WPML products and let me know if the problem has not yet been resolved.