Skip Navigation

[Resolved] Can’t open the block editor trying to edit product archive

This thread is resolved. Here is a description of the problem and solution.

Problem:

I can not open up Block Editor and it throws a Javascript error in the console.

Solution:

Please clear your browser cache and try again.

Checking with another browser showed the editor.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Diego Walter Ricciardi 8 months, 4 weeks ago.

Assigned support staff: Christopher Amirian.

Author
Posts
#2312209

I try to enter the editor like always:

TypeError: Cannot read properties of null (reading 'getContentSelection')
at c (hidden link)
at hidden link
at hidden link
at Le (hidden link)
at Re (hidden link)
at Pj (hidden link)
at di (hidden link)
at Nj (hidden link)
at sc (hidden link)
at gf (hidden link)

#2312213

Christopher Amirian
Supporter

Languages: English (English )

Hi there,

Would you please kindly do the tests below:

1. Plugin conflict test

- IMPORTANT STEP! Create a backup of your website.
- Go to "WordPress Dashboard > Plugins" and deactivate all plugins except Toolset and its add-ons.
- Check if you can still recreate the issue.
- If not, re-activate your plugins one by one and check the issue each time to find out the plugin that causes the problem.

2. Child Theme conflict test

- IMPORTANT STEP! Create a backup of your website.
- Switch to Astra Theme parent by going to "WordPress Dashboard > Appearance > themes".
- See if the issue is fixed.

Thank you.

#2312431

Hi,

Did both, still the same issue. I hope I haven't lost the archive because it's gonna be a pain in the ass to re-do.

#2312923

Christopher Amirian
Supporter

Languages: English (English )

H ithere,

Thank you for testing that.

I need the name of the page that you try to open so I can check. As I also will need to check a possible plugin conflict and other environmental factors I need you to create a staging version of your website, you can ask your hosting service provider to create one for you.

Or you can give me permission to do the plugin and theme test on your live website. If that is the case, I need you to make sure you have a COMPLETE backup of your website before giving the login information.

Please make sure that the next reply is private when sharing the login info.

Thank you.

#2314201

I'm sorry I didn't say what I was trying to open:

in wp archives, it's the one and only product archive I have.

#2315295

Christopher Amirian
Supporter

Languages: English (English )

Screen Shot 2022-03-13 at 10.30.57.png

Hi there,

Thank you very much for the login information. I checked the archive page and for me, it is working ok.

I even changed the heading from H5 to H4 in the red text that I shared the screenshot.

I used Google Chrome on Mac. Would you please try to check the editor in another browser or if you have an older version of the browser update it?

Also, it might be a good idea that you clear your browser cache.

If I miss something, or I am supposed to do something that triggers the error please kindly give me the detailed steps to reproduce the error.

Thank you.

#2316645

My issue is resolved now. Thank you!

Very strange, never had browser cache throw critical errors, but I cleared cache and it worked like a charm.