Skip Navigation

Align top of container is actually unset

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by nicholasM 8 months ago.


When you set Vertical alignment on a container you can not Unselect it. you are only able to select Top/bottom/center. When you select top it's essentially not setting this setting, Which I do agree is the most important option, but really there should be a Top/bottom/middle/unset. Because if you have a class that is applying justify-content: space-between; and you select TOP then it will be space between, but if you click center that will overide the "TOP" because TOP isn't actually setting Justify-content: flex-start; which I'm glad it doesn't or we would have to overide it everytime, but it's not super clear for some clients because top might not do what they expect.

So in summery I think there should be 4 settings here, an unset / top /middle / bottom



Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi Nick

I've added a comment to an internal ticket about this feature about the inability to unset this setting, but as you note yourself the unset and top settings are identical in terms of the front-end styles, so I wouldn't expect this to be treated as much of a priority, though the next time we make any changes to this component it may be possible to update it to be able to unset the setting once chosen.


My issue is resolved now. Thank you!