Skip Navigation

[Closed] AJAX search is automatically removing one results. It's as if we set an offset.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Jamal 1 year, 2 months ago.

Assigned support staff: Jamal.

Author
Posts
#1736547

We have a view setup that loads all 15 results initially on page load. But when you use a filter with AJAX result refresh, the results always have the 1st item automatically removed. If I set the page to full refresh then it works as intended. So the issue only seems to be with AJAX.

Here is the page: hidden link -- The password to view the page is 1234

Any idea what could cause this behavior?

#1737313

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting the Toolset support.

It smells like a caching issue. Can you deactivate caching if a caching plugin is activated?
can you check from a server-side if any caching mechanism is implemented? you may check this by building a copy of your website locally or on another server?

Please check if this issue appears when:
- Only Toolset plugins are activated. It will tell us if there is an interaction issue with another plugin.
- The theme is set to a WordPress default like Twenty Fourteen. It will tell us if there is an interaction issue with your theme.
If the problem disappears, start activating one at the time to track where the incompatibility is produced.

#1739931

Thanks for the reply, Jamal. We are investigating and will get back to you to let you know what we find.

#1740219

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you Marcus for this feedback. I'll currently set this ticket as waiting for your reply, it should be kept open for 3 weeks.

If what I suggested above is not helping find the root cause, I'll need credentials to be able to see this error. The page is currently protected and I cannot play with the view to see what is happening. If you may also record a short video or explain in details what result is missing on the AJAX reply, that would help me understand it quickly and analyze it quickly.

If you can afford a staging site, that would be helpful, that way I can run whatever test I need without impacting your site visitors. Your next reply will be private to let you share credentials safely. ** Make a database backup before sharing credentials. **

The topic ‘[Closed] AJAX search is automatically removing one results. It's as if we set an offset.’ is closed to new replies.