Skip Navigation

[Resolved] Mobile view problems

The Toolset Community Forum is closed, for technical support questions, please head on to our Toolset Professional Support (for paid clients), with any pre-sale or admin question please contact us here.
This is the community support forum for Types plugin, which is part of Toolset. Toolset is a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients and people who registered for Types community support can post in it.

Tagged: 

This topic contains 21 replies, has 3 voices.

Last updated by Adriano 6 years, 5 months ago.

Assigned support staff: Adriano.

Author
Posts
#292482
Screen Shot 2015-03-30 at 2.23.50 PM.png

I am trying to: Use Views to display recent posts from my blog correctly on my mobile site.

I visited this URL: hidden link

I expected to see: The three blog posts fitting across the page, or stacked one on top of the other when in mobile view.

Instead, I got: The posts don't fit on the screen and are chopped off.

My theme is mobile-ready and all other modules are working correctly. Can you help?

#292636

Hi Erin,

Please attach an image of your View, I need to see how you configured it. A full screen image would be perfect.

#292681
Screen Shot 2015-03-31 at 10.42.42 AM.png

Here is the image.

#292926
Captura de Tela 2015-04-01 às 14.49.10.png

Hi Erin,

It's because in that way your View isn't responsive. I'd recommend you to use the Bootstrap grid format, as you can see in the attached image.

Please let me know if you are satisfied with my reply and any other questions you may have.

Regards,

Adriano Ferreira

#292988

I'm trying to add Bootstrap to Divi using these instructions:
https://toolset.com/forums/topic/responsive-grid-layout-2/#post-262330

I can't add the chunk of php code listed in that thread to the functions.php file without getting the white screen of death.

So, of course, it's not working. Can you help with this?

I'll attach a screenshot of the bootstrap code I have in place. I want the Recent Posts section in the home screen to have 3 posts next to each other.

#293184

Hi Erin,

You forgot to attach the image.

When you receive the white screen means something happened on your site and your PHP log will say it. Please add the following lines inside of your wp-config.php file:

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . 'https://cdn.toolset.com/error_log.txt');

This will produce a file called ‘error_log.txt’ in your WordPress root directory. Make sure that the web server can create and write this file. If it cannot, use an FTP program to create the file and make it writable to Apache (normally, user www-data).

I need that file to understand why you are receiving that white page in order to help you to fix that.

#293196
Screen Shot 2015-04-01 at 5.33.01 PM.png

Sorry about forgetting the screenshot, it's here.

And here is the error message:
[02-Apr-2015 18:33:05 UTC] PHP Parse error: syntax error, unexpected '{' in /home/admin/domains/profitablepopularity.com/public_html/wp-content/themes/Divi/functions.php on line 5001
[02-Apr-2015 18:33:05 UTC] PHP Parse error: syntax error, unexpected '{' in /home/admin/domains/profitablepopularity.com/public_html/wp-content/themes/Divi/functions.php on line 5001
[02-Apr-2015 18:33:06 UTC] PHP Parse error: syntax error, unexpected '{' in /home/admin/domains/profitablepopularity.com/public_html/wp-content/themes/Divi/functions.php on line 5001

Line 5001 is this code (I numbered the lines to help):
5000 function wpbootstrap_register_scripts() {
5001     if ( ! is_admin() ) {
5002  
5003         // Deregister styles
5004         wp_deregister_style('wpbootstrap_bootstrap_responsive_css');
5005  
5006         // Register Twitter Bootstrap CSS files
5007         wp_register_style('wpbootstrap_bootstrap_main_css', get_template_directory_uri() . 'https://cdn.toolset.com/bootstrap/css/bootstrap.min.css', false, null);
5008         wp_register_style('wpbootstrap_bootstrap_theme_css', get_template_directory_uri() . 'https://cdn.toolset.com/bootstrap/css/bootstrap-theme.min.css', array('wpbootstrap_bootstrap_main_css'), null);
5009  
5010         // Register Twitter Bootstrap JS
5011         wp_register_script('wpbootstrap_bootstrap_js', get_template_directory_uri() . 'https://cdn.toolset.com/bootstrap/js/bootstrap.min.js', array('jquery'), null, true);
5012  
5013         // Enqueue Twitter Bootstrap CSS files
5014         wp_enqueue_style('wpbootstrap_bootstrap_main_css');
5015         wp_enqueue_style('wpbootstrap_bootstrap_theme_css');
5016  
5017         // Eneuqueu Twitter Bootstrap JS
5018         wp_enqueue_script('wpbootstrap_bootstrap_js');
5019     }
5020 }
5021 add_action( 'wp_enqueue_scripts', 'wpbootstrap_register_scripts' );

#293349

Waqas
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

This is Waqas here, on behalf of Mr. Adriano. He's on vacation and will join back on Monday.

He will follow up with you, as soon as he returns. Thank you for your cooperation and patience.

Have a nice day.

#294038

Hi Erin,

I've just pasted your code on my localhost and it worked. It means that the problem isn't there. Could you share the entire code of your functions.php file? You could use pastebin: pastebin.com

I think that the problem is just before that function.

#294068

Here's the pastebin:
http://pastebin.com/SZcCQLnu

I tried moving the code to see if I got a different result, and alas, no.

And just to clarify, I get the white screen on the WordPress admin panel when I use that code. The website still shows up (though I'm still not getting the horizontal tiling that I want).

#294114

Hi Erin,

I've fixed your code, some extra spaces, please try with this one: http://pastebin.com/sxRAUxZx

Please let me know if you are satisfied with my reply and any other questions you may have.

Regards,

Adriano Ferreira

#294148
Home 2 | Profitable Popularity (20150306).png
Screen Shot 2015-04-07 at 5.58.16 PM.png

That fixed the white screen problem - yay and thanks!

But, the View itself still has major problems. This is what I'm getting now (see first image); and how I want it to display (see the full home page shot, From The Blog section)

And here's the code I'm using to generate the view.
http://pastebin.com

#294367

Hi Erin,

Well, I didn't receive the code of your View.

#294375
#294424

What kind of content is stored in "wprss_item_thumbnail"? The image's path?

The forum ‘Types Community Support’ is closed to new topics and replies.