Skip Navigation

[Résolu] Most custom posts not displaying – getting critical error message

This support ticket is created Il y a 1 an et 8 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 réponses, has 2 voix.

Last updated by Robert Campbell Il y a 1 an et 8 mois.

Assigned support staff: Minesh.

Auteur
Publications
#1810623

Today one of my live client websites hidden link stopped displaying most custom posts and I got the 'critical error' message. I managed to fix the problem by deactivating Views and loading and activating the Blocks plugin. This website was not built using Layouts.

I got no warning that running a website based on Views would fail catastrophically. Could you please advise urgently what is the situation with the Views plugin? Do you have any idea what could cause such a catastrophic failure? Could it be related to the WordPress Block Editor?

I have other websites still running with Views but these were built using Layouts and I have just read your warning that the Blocks and Layouts plugins are not recommended to use together, so what should I do with these websites?

One extremely worried client!

Regards

Robert

#1810915

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

First of all, there is nothing to worry about as Toolset support is always available and happy to help.

I do not see any other user reported such issue which you are reporting here.

First of all, Toolset Blocks and Toolset Views are the 1:1 copy of each other. We just renamed the name of Toolset Views to Toolset Blocks where we are more focused on Toolset Blocks and interested to add more features where we keep supporting the Views plugin.

As you see the critical error, are you sure the issue was from the views plugin? if yes:
- it could be the possibility that automatic updates went wrong and even we can not discard any other possibility like conflict with other plugin or wordpress version. But as acknowledged, I do not see any other user reported the same issue.

If I can see the issue and what critical error is there then I can investigate and happy to help you further.

I have other websites still running with Views but these were built using Layouts and I have just read your warning that the Blocks and Layouts plugins are not recommended to use together, so what should I do with these websites?
==>
Here is the blog post which you should read about how you can use the Blocks plugin on existing site:
- https://toolset.com/2019/12/using-toolset-blocks-on-existing-toolset-sites/

With your other website, if you are using Layouts and Views, there is no issue, you will just require to set the "Show both the legacy and Blocks interface and let me choose which to use for each item I build" option from:
=> Toolset => Settings => General tab => Editing experience

That will allow you to use Blocks and you can use Views+Layouts as well.

Please let me know your feedback.

#1812025

Hi Minesh

Thank you for explaining the situation so clearly. I agree there must have been some kind up update issue. It was certainly not something I had seen before and it affected about 95% of all custom posts on the site. Since I updated to the latest version of Blocks all has been well.

I will take your advice for my other sites which were built using Layouts.

Best regards
Robert