Skip Navigation

[Résolu] Error After Latest Update

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem:
Pages templates aren't being loaded after Toolset Layouts plugin update

Solution:
- As a basic step, and to figure out the problem cause, disable all non-Toolset plugins and activate a default theme like "Twentyfifteen" then test the issue.

- If you figured out which plugin/theme causes the conflict, please open a new ticket and mention your findings

- For the currently displaying issue, it was a problem with the template loading order

- For example, this filter has a priority (99) add_filter('template_include', array('Roots_Wrapping', 'wrap'), 99);

- Increasing 99 to higher value solved the issue. But this is a special case of this theme.

Relevant Documentation:

This support ticket is created Il y a 8 années et 1 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 10:00 - - - - -
- - - - - - -

Supporter timezone: Africa/Cairo (GMT+02:00)

This topic contains 22 réponses, has 4 voix.

Last updated by Jo4nny8 Il y a 8 années et 1 mois.

Assisted by: Mohammed.

Auteur
Publications
#373719

Hi John,

It's a filter priority issue in file :\wp-content\themes\aquariusHI\lib\wrapper.php
at line 60
So,I was able to solve the issue by replacing this line

add_filter('template_include', array('Roots_Wrapping', 'wrap'), 99);

By this:

add_filter('template_include', array('Roots_Wrapping', 'wrap'), 110);

Please try it and let me get your feedback.

Thanks.

#373937

Hi

Thanks for that. Unfortunately for some bizarre reason it doesn't work. Ive made the changes on the test area we were using (local-handy-man.co.uk) and it works.

However, when making the changes on my production site, it doesn't work? It stays wrong as before the update. Ive cleared the cache, disabled all plugins etc but to no avail. The psychical server is the same one so it can't be a server issue. Can you offer any advice why it might be working on one site but not another?

John

#374475
Bathrooms Derby & Kitchens Derby by Aquarius - Google Chrome 2016-03-09 23.51.39.png

Hi John,

I see that your test website is working well now .Which proves that the fix is working.

Please check if the hosting provides any caching for the production website and ask them to remove it completely.

If you are using a caching plugin, the best way to make sure that the cache is cleared is to do the following:
-Deactivate the caching plugins
-Comment out any lines of code that are related to any caching plugins by preceding these line by these characters "//" without the double quotes
-Delete any caching folders and files

If this didn't work for you, please provide me an access to the production website Admin and FTP.
I will set the next reply as private one so that you ca provide these information securely.

PLEASE, take a complete backup of your website before providing the credentials.

Thanks.

#375001

Ill check the above and let you know after the weekend. Many thanks

#375122

Hi

Im sorry but i can't seem to fix it. Please can you set the next reply as private so i can allow you access to my production site.

I am using a slightly different plugin arrangement now, however i have performed the changes on a development site and it still produces the same error with no caching, magnification etc in place so I'm not sure whats going on.

#375359

Hi John,

I'm setting the next reply as a private one. you can provide the Admin and FTP access credentials securely.

Thanks.

#376075

Hi John,

I've increased the priority of the filter to be 1000 and it works now.
This is the updated line of code

add_filter('template_include', array('Roots_Wrapping', 'wrap'), 1000);

I hope that your problem is solved now.

Thanks.

#376219

Thats great thank you very much for you time and help!

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.