Skip Navigation

[Résolu] Search by location doesnt work in some ocasions

This support ticket is created Il y a 5 mois et 3 semaines. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum Jeu d'outils. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

Ce sujet contient 17 réponses, a 2 voix.

Dernière mise à jour par zeljko-turkaljS Il y a 5 mois et 2 semaines.

Assisté par: Minesh.

Auteur
Publications
#2679520

I have a directory website build: lien caché.

lien caché

If you check search by offices, you will see that we have option to enter office name and agent name in search form. That all works as expected.

If you try the Jacksonville, Fl for location and for example 20 miles radius it will also work. But, for example if you enter Orlando and 20 miles, it will return all results, or at least we believe those are all results. Seems like the map is just reloading, not showing the results.

Can you help me with this issue?

Thanks in advance
Sasa Vidakovic
Deal Studio

#2679645

Minesh
Supporter

Les langues: Anglais (English )

Fuseau horaire: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Yes - it does seem that map is just reloading rather filtering the results.

I will have to review your current setup in order to check how you configured the map.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I have set the next reply to private which means only you and I have access to it.

#2679800

Minesh
Supporter

Les langues: Anglais (English )

Fuseau horaire: Asia/Kolkata (GMT+05:30)

I've added the following line to know the total items found within your view's "Loop Editor section": Total: [wpv-found-count]
- lien caché

I can see when you load the page first time: lien caché
- I can see Total: 260 results (just above of the map)

Now, when I apply the "ORLANDO, FL, USA" and 20 miles, it shows me total 46 results:
- lien caché

That means it seems to be working.

#2679834

Hi Manish, thanks for your feedback.

Did you change anything else in this view, or did you just apply the total count shortcode.

Regards

#2679840

You can check this same preset on production environment

Orlando, 20 miles
---
lien caché

The map is just reloading with same results

#2679985

Hi Minesh, one more thing. On the dev environment, if you search by location Tampa, radius 20 miles, you will see that he map is also reloading same as on production for Orlando

development (Tampa, 20 miles)
lien caché

Regards

#2680428

Minesh
Supporter

Les langues: Anglais (English )

Fuseau horaire: Asia/Kolkata (GMT+05:30)

I checked the staging site and I can see few results with the URL you shared:
- lien caché

Please check the following video:
- lien caché

There must be cache on server side or browser if you see the different result.

#2680463

Hi Minesh, apologies. We are building CSV import plugin for those offices and brokers, and you probably see only few of them now.

Will it help if we give you access to production environment (bbfmls.com)? If you agree with that, you can mark next reply private and I will send you the admin login link.

Please let me know

Regards

#2680559

Minesh
Supporter

Les langues: Anglais (English )

Fuseau horaire: Asia/Kolkata (GMT+05:30)

I have set the next reply to private which means only you and I have access to it.

#2680607

Minesh
Supporter

Les langues: Anglais (English )

Fuseau horaire: Asia/Kolkata (GMT+05:30)

I see on your map's settings page:
- lien caché

I can see the error with the API key you registered:

REQUEST_DENIED - API keys with referer restrictions cannot be used with this API.

Can you please try to register valid and working Google Map API key and check again.

#2680608
Screenshot 2024-01-30 at 13.13.25.png

Hi Minesh, I don't have any restrictions in console, except for domain

On that page, you mention above, I don't see any issues :), please recheck that on your end once more

Regards
Sasa

#2680609

Minesh
Supporter

Les langues: Anglais (English )

Fuseau horaire: Asia/Kolkata (GMT+05:30)

You will have to click on the button "Check API" and you will see the error.

As the error suggest you will have to register unrestricted Google Map API key so you will have to remove all those domains for your API key.

#2680614

Are you suggesting that we need to not restrict the key and then the map will work?

#2680615

Yes, this is working now, but this is not acceptable for us. We need to restrict the key

What are your suggestions on that?

#2680623

Minesh
Supporter

Les langues: Anglais (English )

Fuseau horaire: Asia/Kolkata (GMT+05:30)

I do not have any other solution on this. Maybe you should try to create a server-side API key and the one that you already registered and check if that helps.

zeljko-turkaljS a confirmé que le problème avait été résolu sur 2024-02-01 11:31:36.
Ce ticket est maintenant fermé. Si vous êtes un client de Toolset et que vous avez besoin d'aide, veuillez ouvrir un nouveau ticket d'assistance