Skip Navigation

[Résolu] Load more button using the pagination

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 15 réponses, has 2 voix.

Last updated by Ido Angel Il y a 10 mois et 2 semaines.

Assigned support staff: Waqar.

Auteur
Publications
#1817281

hey
i've assigned a "load more" button according to this thread: https://toolset.com/forums/topic/load-more-button-3/
here: hidden link
(the blue button with a "down" arrow at the middle of the page)
but when i press it, all first 6 initial items are removed, 6 new items are loaded, and only then the button acts properly, e.g loading more results to the current ones

#1819797

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Ido,

Thank you for waiting.

During testing with the latest Types and Blocks plugins on my website, I couldn't reproduce this issue.

With infinite scrolling turned on and settings the same as your screenshots, the "wpv-pager-next-page" shortcode loaded the next page items, without removing the existing ones.

Are you using any custom script on the page that could interfere with this AJAX loading?

It would be interesting to test this with all extra plugins disabled and a default theme like Twenty Twenty.

Please let me know how it goes.

regard,
Waqar

#1821267

I have a replica of the site here:

hidden link

i disabled all plugins except toolset, woocommerce and elementor, then activated the 2019 theme - and still the same
you can access with the same credentials there...

thx!
ido

#1828111

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Ido,

Sorry about the delay in getting back on this.

I had unsually busy forum queue, but I'll be able to share my findings, by the end of the day today.

Thank you for your patience.

regards,
Waqar

#1831553

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Ido,

Thank you for waiting.

Unfortunately, I'm still getting different results on your websites as compared to my test website.

Would it be possible for you to share a clone/snapshot of this replica website so that I can troubleshoot this on my server?
( ref: https://toolset.com/faq/provide-supporters-copy-site/ )

Note: I've set your next reply as private.

regards,
Waqar

#1834255

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Ido,

I've downloaded the 3 GB duplicator package a couple of times and tried to extract it on a few different computers, but it keeps showing the "invalid file" message.

Can you please share the temporary admin access details of the replica website again, so that I can download the duplicator package directly from it?

Note: your next reply will be private.

regards,
Waqar

#1835127

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

I can access the website's front-end, but whenever I try to access the admin area, I get blocked by the Cloudflare's firewall with a message: "Error 1020 Access denied".

Note: I tried to access it through different regions of the world using a VPN, but couldn't bypass the firewall rules.

Would it be possible for you to disable this firewall protection until I download the duplicator package?

If not, you can create the duplicator package and share it's two files, but exactly as shared in our guide on the topic.
( ref: https://toolset.com/faq/provide-supporters-copy-site/ )

#1835131

thx Waqar and sorry for the trouble. Can you send me your ip so I can open it?

#1837699

Waqar...

#1837763

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Did you check my message from Nov 5th where I sent my IP address?

It has now changed to 119.154.20.224.
( unfortunately, I don't have the static IP these days )

I would still request you to either temporarily disable the firewal to access the website's admin area or share the duplicator package's two files, as recommended earlier.

I'm also going to share the admin access for a test website, in my next private reply. Maybe, you're able to recreate the issue with the load more button on it?

#1837775

didn't get it...
can you please try with this ip in an hour from now?
thx!

#1837777

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Tried to access the admin area just now, but it is still showing the same message.
( screenshot: hidden link )

Note: My IP address is still the same: 119.154.20.224

#1837785

Yes that’s why I said in an hour...
But it’s white listed now, pls try again
Thx

#1837787

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

I've managed to download the duplicator package, thank you.
( you can remove the whitelisting now )

I'm going to deploy this clone on my server and will share my findings, accordingly.

#1838699

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for waiting.

During testing your website's clone on a couple of different servers, I couldn't reproduce the issue.

The results from the view "All Mags" keep adding to the initial list, whenever the load more button ( "בא לי עוד" ) is clicked.

Here is the link to the page from my test website:
hidden link

This suggests that either your server or Cloudflare is caching the initial results/database call and after the first load more button's click, the view's paginated results are shown correctly.

I'll recommend to get in touch with your host or Cloudflare's support to see if there an option to exclude the WordPress AJAX calls from being cached.