Skip Navigation

[Résolu] Error

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 réponses, has 3 voix.

Last updated by prasadS Il y a 3 années.

Assigned support staff: Luo Yang.

Auteur
Publications
#917073
Screen Shot 2018-06-24 at 5.42.34 PM.png

I am trying to:
Update a post in my custom post type named 'Activities'.
I have another custom post type named 'Reviews'. In the post there is a radio field named 'Review Rating'.
Activities and Reviews have a one-to-many relationship.
Every time I update an Activity post, I get an error message displayed. (screenshot also attached). The error message says: Field "Review Rating" not updated: This field is required.

While the post gets updated of any changes I do, The error message is displayed every time.

I expected to see: No error message.

#917286
Screen Shot 2018-06-25 at 11.07.34 AM.png

Just now, I tried to update one post under my custom post type 'Activities'.

This post has several 'Reviews' linked to it.

After I updated the post, the content was updated, but the error was displayed (Please see attached screenshot)

#917334

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

How do you setup the "Review Rating" field? Please check these:
1) edit the field group of "Review Rating" field, make sure it is register to post type 'Reviews', not the post type 'Activities'

2) Deactivate other plugins and switch to wordpress default theme 2017, and test again

3) If the problem still persists, please provide provide a database dump file (ZIP file) of your website in below "private detail box", I need to duplicate same problem and debug it in my localhost, thanks.

#917351

Apologies for butting in but I have this issue too. It's been reported via ticket https://toolset.com/forums/topic/errors-shown-for-empty-required-fields-in-parent-posts/, Christian has escalated and sent my site dump files to 2nd tier support

#922634

Hello.

Apologies for the delay in responding. I was away from my computer for a long time.

1) I checked this. The 'Review Rating' field is registered under the post type 'Reviews' and not 'Activities.

2) I will switch to the default theme and disable everything else. Will let you know the results in a few hours.

Thank you again and apologies for the delay in replying.