Skip Navigation

[Résolu] CRED form emails – with Expiry settings

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 64 réponses, has 3 voix.

Last updated by lindsayH Il y a 3 années et 11 mois.

Assigned support staff: Beda.

Auteur
Publications
#566840

Can I clone my form? And test that?

#567065

Well, yes, of course.
In Toolset > Post Forms > any_form you can duplicate forms.

Or you can just create a new one. I think, to test it, it would be better to create a new one, but I understand you want to clone maybe due to the form's complexity.
You could create a new one with just the basic needed settings.

I suspect, this is related to the same issue, and if we get this confirmed, we can try to find the BUG.

I can also help you do that on the staging site, please let me know.

#567498

Hi, this does appear to indeed be solved. Thank you very much for your time and tenacity.

#567510

I just realised... that my test has worked. I copied the CRED form (didn't clone), but I did set it up with exactly the same settings and the same Content.

The main difference is I only used one email notification, the one we're testing - to be sent before the automatic expiration date.

My original CRED form, I'm still not receiving any emails now - for this particular email notification.

Not sure whether to try to clone now and see what happens. I'd like to do this on a test site. So maybe when you've finished testing re my other issue I can try there?

#567532

Yes, if you wish, we can do that there, but let's first solve the other issue (I believe it is).

#568570

Trying to solve other issue first. But bot wanting to close this.

#568593

OK.

#570213

As above, bot trying to close.

#574030

Lindsay, I apologise, we cannot let this sleep here.

It is my mistake, I will now immediately set up another test server to also re-test this issue, as the other one will not be solved overnight.

I need from you a confirmation:
- are we still speaking only and solely about this exact issue:
https://toolset.com/forums/topic/cred-form-emails-with-expiry-settings/#post-468650

If so, I will set everything up on a fresh install and then let's test.

#574099

OK, will retest.

#574383

All I need to know if the initial issue is still the same - as by my knowledge it should be.

Then I set up the environment to proceed.

Thank you, Lindsay, for your patience.

#575033
Expiry Date.png

With regards my test on my staging site, I didn't receive any emails at all. But when I looked at the suppiers they hadn't changed to Pending either?

The post settings expiration date are correct on the post itself (see image attached). But nothing?

#575043

I see.

The initial issue of this bug is:

1. A Create Content CRED Form

2. Set an Email to be sent to the author, is triggering a certain amount of time before the automatic expiration happens

3. If 2 users with complete different Account Details are adding such a post, the Email is sent to the first submitted Post (User)

Now, it seems you confirm the issue changed to "Now no email is sent at all".
This BUG we will continue to trace and try to solve here.

The other, related to the status not changing, is not related to this report.

Can you please separate this from the thread and open a new one, in case it is needed?

In future, we will have a method for us supporters to split the thread directly, right now thou I need to ask you if you can help me with this 🙂 and create a new thread for the add-on issue.

I checked the remaining issue on a live site.
I am awaiting wether or not I get the emails, and who gets them.

Please await my reply here in regard to this.

#575084

I will do another test. I'll have a go next week and let you know. I'm not sure about the status as it was done on my old staging site - so maybe something else affected that. I'm going to copy my site over again and test on this updated staging site.

It does seem though that emails are failing to come through at all now (where I used to get two to one email account), but only when applying the particular settings you've numbered above #575043. I've tried a couple of times in my recent comments and indeed have not received anything.

#575592

No emails here too.

I am reopening the internal tracker.