Skip Navigation

[Résolu] Can't translate Repeatable Field Group with WPML Classic Translation Editor

This support ticket is created Il y a 2 années et 5 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

This topic contains 10 réponses, has 3 voix.

Last updated by fred-r.M Il y a 2 années et 3 mois.

Assisted by: Minesh.

Auteur
Publications
#2179373

I am trying to: W are having in a Field Group a Repeatable Field Group with 3 additional fields. We like to translate them but this isn't working, as we don't see the translation in the WPML Classic Translation Editor

We followed this document: https://toolset.com/course-lesson/translating-repeatable-field-groups/

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

#2179589

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting Toolset support.

I logged into your website and inspected the existing RFGs, there is only RFG out there. It is assigned to the Products post type. I am afraid, you missed the first step of our tutorial. The associated post type(product) is not configured to be translatable. Check this screenshot hidden link
https://toolset.com/course-lesson/translating-repeatable-field-groups/#1-make-the-associated-post-type-translatable

Make the Products post type translatable, and try to translate a post, I am sure you will get the RFGs item in the translator editor.

I hope this helps. Let me know if you have any questions.

#2182855

Dear Jamal

I checked all settings as described, but I still not see the fields to translate:

The fields I need are:

wpcf-itinerary ((Repeatable Group))
wpcf-itinerary-intro-title
wpcf-stage-title
wpcf-meals
wpcf-description

We don't use the WPML's Classic Translation Editor.

If You might check it out, what I might have done wrong?

Regards,

Simon

#2184565

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

All the settings seem correct to me. I will need to take a copy of your website and analyze it locally. Can I install a plugin(Duplicator) to take the copy?

#2189675

Dear Jamal

You find the package from the duplicator already ready to download.

Regards,

#2190831

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you! I took a copy and confirm the issue on my local setup. It also seems to be a new bug, because I was able to reproduce this issue on a clean install too. I am escalating this to our 2nd Tier team for further analysis, and I'll get back to you as soon as possible.

On the other hand, if I disable WooCommerce Multilingual(WCML), and update the RFG items of a product, they get picked for translation.
I wouldn't recommend temporarily disabling WCML as a workaround. Especially, because several parts of the store rely on WCML(checkout, cart, etc.). So, if you would like to try it, please take a database backup before doing it.

#2195483

Dear Jamal

Thanks for the reply, and sorry for our late reply.

We are somehow aware about the WCML disabling. So You advise as first, to disable it, to get the fields for translate, then enable it for all other stuff we need for it?

#2196647

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Well, I did reproduce the issue with the Classic Translation Editor(CTE), but the issue was not reproduced with the Advanced Translation Editor(ATE). You can log in to my test site with this URL hidden link

And you can see on this product, that the RFG fields are picked for translation, and translated, using the ATE hidden link

So, I'd like to ask, what editor would you want to use for translating the products? The classic or the advanced editors?
If you want to use the Advanced editor, enable it in WPML->Settings, then try to translate a product and let us know if the RFGs will be picked and translated.

If you would want to use the Classic Translation Editor or to translate manually, I'll check again with our 2nd Tier team and get back to you.

#2205671

Dear Jamal

We prefer to use the Classic Editor, especially as we already did a lot of translations with it.

For a futured project I will keep in mind, to use the Advanced Editor.

#2206025

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Jamal is on Vacation. This is Minesh here, let me step-in here.

We emphasize to use Translation Editor that is the suggested workflow for the translation. Even I will report the issue if confirmed then it will take long time as its totally depends on our Devs predefined priority and current engagements and there is no ETA when will the official fix will be offered for this issue.

I suggest you should go with translation editor as of now.

#2209443

For now, this issue is resolved. Even if we not use the Advanced Translation Editor(ATE). We was able to get it done, as the fields was "copied" over, and we was able to fill with the translation. Only the item title we kept in English, the fields in each item we could add our translation.

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.