Skip Navigation

[Résolu] Can't edit posts with Types active

This support ticket is created Il y a 6 années et 9 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 14:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Jamaica (GMT-05:00)

This topic contains 18 réponses, has 4 voix.

Last updated by oleg-2 Il y a 6 années et 9 mois.

Assigned support staff: Shane.

Auteur
Publications
#387850

I am trying to: edit a regular post

I visited this URL: Posts > All Posts (OK up to here) > Edit Post Page (where problem started)

I expected to see: WordPress post editor, categories, tags, and other standard meta boxes.

Instead, I got: A blank white screen.

I am able to get to the post edit page if Types is deactivated, but once it is active I am unable to get to the post edit page.

Also I attempted to provide the system configuration information but I can't find where it is anymore. It used to be in a help menu, but it seems like that has moved. I'd be happy to provide the information if you can point me in the right direction.

#387929

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Scott,

Thank you for contacting our support forum.

The issue you are experiencing here seems similar to the one that has been fixed in our erratas page.

What I recommend that you do is to take a look at the page we have below and try this fix.

https://toolset.com/errata/unable-save-admin-bar-options-types/

Also just checking if you have the visual composer plugin installed.

Thanks,
Shane

#387948

I made the fix as the other article suggested, but it did not help. Specifically, I am still seeing the same white screen when I try to edit a post.
One thing the other article mentioned was not having Views installed, although this site does have Views installed.
This site does not have visual composer installed either.

#389618

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Scott,

Thank you for trying.

Would it be possible for you to provide me with admin and ftp access to the website so I can perform some debugging on the website?

The private fields will be enabled for your next response.

Thanks,
Shane

#389734

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Scott,

It seems that your server is generating a 500 error.

What you need to do is contact your hosting provider so that you can get access to the error logs of your server.

This will allow you to know what exactly is causing the internal server error.

From here we will know the next step.

Thanks,
Shane

#389747

The last two errors in the error log detail the 500 error you were seeing.

[Mon Apr 18 19:49:50 2016] [error] [client 70.162.114.66] PHP Fatal error: Call to undefined function hash() in /home/*****/www/******.com/wp-content/plugins/types/library/twig/twig/lib/Twig/Environment.php on line 316, referer: hidden link
[Mon Apr 18 19:51:22 2016] [error] [client 70.162.114.66] PHP Fatal error: Call to undefined function hash() in /home/*****/www/******.com/wp-content/plugins/types/library/twig/twig/lib/Twig/Environment.php on line 316, referer: hidden link

I removed the domain/username for security purposes, but you should be able to trace this error using the FTP login info I sent you earlier.

#389757

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Scott,

Would you mind creating a duplicator package of your website for me?

You can do this by installing the plugin below.
https://wordpress.org/plugins/duplicator/

This will allow me to download the package and create a duplicate of your website.

Thanks,
Shane

#389772

Duplicator isn't working on the site - it says Zip Archive Enabled Failed. I don't have access to the php.ini to enable it, so I'm not sure what else to do.

#390285

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Scott,

I want to be able to test this site on a different server environment to see if its an actual server issue 🙁

Would it be possible to contact the hosting provider so they can enable it for you ?

This will be really helpful and in the event I need to escalate your ticket we will need a duplicator package.

Thanks,
Shane

#390287

I have a backup of the site that I can send you if that will help? If I can have a private post I can send you a link to the backup download files. The host has been very unhelpful with this sort of thing.

#390346

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Scott,

The private fields have been enabled.

Thanks,
Shane

#390602

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Scott,

I'll need a database backup as well in order to restore the website.

Could you ask your hosting provider to provide you with a a backup of the database.

Thanks,
Shane

#390719

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Scott,

I have good news. The issue seems to be server related. I was able to restore the backup on my local server and everything worked fine with no issue at all.

Would it be possible to contact your hosting provider and ask them if the hash() php module is enabled?

If not then you will need to enable it.

Thanks,
Shane

#390752

Thanks, I'm reaching out to them now and hopefully can get this resolved. I will let you know once I hear back.

#390757

The host was asking which type of hash PHP extension we were referring to. I assumed they would be able to help with this, but could you provide any background on what they should be enabling?