Skip Navigation

[Résolu] Call to undefined function WP_Filesystem() in class-otgs-installer-source-factor

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 réponses, has 3 voix.

Last updated by Christian Cox Il y a 1 an et 8 mois.

Assigned support staff: Christian Cox.

Auteur
Publications
#1416569

We are getting the same error that was in this ticket, on SEVERAL of our sites:
https://toolset.com/forums/topic/urgent-wordpress-caught-a-fatal-error-with-one-of-your-plugins-toolset-types/

I am mentioning keithgunterexcavating.com as an example, but we've been getting this error on all of our Toolset sites since WP 5.2 was released.

What triggers the "your site is experiencing a technical issue" email, is apparently the daily iThemes Sync process to check our sites to see what plugin/theme/core updates may be available. That process happens at 8:30 every morning, and at 8:30 every morning we get the emails. Not every site reports this issue every day, but every site reports this issue periodically...some nearly every day, some only once a week or so, but every site with Toolset Types does generate the email.

The sites do not have any ill effects on either the frontend or backend, but since we continue to get these emails I wanted to report the issue.

Here is the text of the email from the site referenced, but it's the same error for all.

When seeking help with this issue, you may be asked for some of the following information:
WordPress version 5.3.2
Current theme: Gunter 2019 (version 2019.02.14.48) Current plugin: Toolset Types (version 3.3.8) PHP version 7.3.3-1+ubuntu14.04.1+deb.sury.org+1

Error Details
=============
An error of type E_ERROR was caused in line 6 of the file /home/s3731/html/wp-content/plugins/types/vendor/otgs/installer/includes/class-otgs-installer-source-factory.php. Error message: Uncaught Error: Call to undefined function WP_Filesystem() in /home/s3731/html/wp-content/plugins/types/vendor/otgs/installer/includes/class-otgs-installer-source-factory.php:6
Stack trace:
#0 /home/s3731/html/wp-content/plugins/types/vendor/otgs/installer/includes/upgrade/class-otgs-installer-upgrade-response.php(128): OTGS_Installer_Source_Factory->create()
#1 /home/s3731/html/wp-content/plugins/types/vendor/otgs/installer/includes/upgrade/class-otgs-installer-upgrade-response.php(63): OTGS_Installer_Upgrade_Response->append_site_key_to_download_url('hidden link...', 'L4dV1JaI68', 'toolset', 'hidden link...')
#2 /home/s3731/html/wp-includes/class-wp-hook.php(290): OTGS_Installer_Upgrade_Response->modify_upgrade_response(Object(stdClass))
#3 /home/s3731/html/wp-includes/plugin.php(206): WP_Hook->apply_filters(Object(stdClass), Array)
#4 /home/s3731/html/wp-includes/option.php(1832): apply_filters('pre_set_site_tr...', Object(stdClass), 'update_plugins')
#5 /home/s3731/html/wp-includes/update.php(334)

#1417181

Hello, and thanks for the report. Our developers are aware of an issue in the Toolset installer system that seems to be triggering fatal errors during automatic update processes and cron jobs that hit those processes periodically. I will connect this ticket with our internal report so I can keep you up-to-date here. If a patch or hotfix becomes available, I will let you know as soon as possible. Thanks for your patience while we resolve this.

#1440961

This issue should be addressed in Types 3.3.9. I'll update this ticket as soon as the update is available.

#1464315

We also have this issue on one of our sites. We have updated to 3.3.9... Is there any more information on this?

#1467607

Hi, Types 3.3.9 is now available for automatic update or download from https://toolset.com/account/downloads. Please update to the latest versions of all Toolset software and let me know if the issue is not fully resolved.