Skip Navigation

[ Corrigé dans la version suivante] Autocomplete not working on address field

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 réponses, has 2 voix.

Last updated by Waqar Il y a 1 mois et 2 semaines.

Assigned support staff: Waqar.

Auteur
Publications
#2076587

Tell us what you are trying to do?
I have a custom post type that uses Toolset's address field. My API Key had the "Google API seems to be configured properly." message in Toolset's settings, so I don't think that's the issue. The address autocomplete works perfectly when inputting an address from the WordPress backend or from a CRED form, but autocomplete doesn't work in my View's search field. I have disabled all plugins except Toolset's, and I'm running the 2021 theme.

Is there any documentation that you are following?
No

Is there a similar example that we can see?

What is the link to your site?
Can provide link to dev site privately

#2076875

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

Do you see any error or warning in the server's error logs or the browser's console, when the address search field doesn't work?

I'm setting your next reply as private, so that you can share temporary admin login details along with the page's link.

regards,
Waqar

#2079269

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the admin access.

I can confirm that this is related to an already reported issue, which is planned to be fixed in the upcoming release of the Toolset Maps, version 2.0.9.

When there is no map showing on the view's page, the autocomplete feature for the distance search field doesn't work.

I'll update you through this ticket once this fixed version is released and for now, the workaround is to include the map on the page, which you can hide if it is not needed.
( screenshot: hidden link )