Skip Navigation

[Résolu] Access and WPML issues after the update

This support ticket is created Il y a 1 an et 5 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 11 réponses, has 2 voix.

Last updated by Jamal Il y a 1 an et 4 mois.

Assigned support staff: Jamal.

Auteur
Publications
#2026245

Hello, I have just updated to the latest versions of Types, Views, Forms and Access over the weekend. I also updated WPML and related plugins.
Since doing this, my site Editors cannot see links to add new posts or edit posts (for regular posts or custom post types).
As an emergency fix, I've had to disable Access from managing those post types.
I realise that this was a known issue between Access and WPML once, but I thought this was resolved.
ANy ideas?
thanks
Alan

#2026389

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

As discussed in the chat, you can report here the results of your tests when you get the time to. I am setting this as waiting for your feedback which should keep it open for 3 weeks.

#2027475

Update: I have cloned the site to run locally on Xampp, and even with all non Toolset / WPML plugins disabled and using the default 2020 theme, I am still seeing the issue whereby the EDITOR roles do not have access to create or edit posts or Custom Post Types, if Posts are set up to be "Managed by ACCESS".
In ACCESS, switching to "Use default WP read permissions" for Posts is necessary to enable Editors to edit and create all post types again.

#2027693

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

That seems like a bug, unless, I am missing something. Would it be possible to take a copy of your website and debug it locally? If yes, please create an administrator user for me and share it in your next reply, which will be private. I'll log in and install Duplicator or All In One Migration to take the copy. You can delete that user later.

#2030707

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you, Alan, I confirm the credentials are working for me. I just need to make sure that I fully understand the issue that you are facing.

I created and edited two (private)posts while Access is still active without issues. One post for the default Post type, that is not managed by Access. And one post from the "Group" post type that is managed with Access:
- hidden link
- hidden link

Am I missing something? What steps should I follow to see this issue?

#2030927

The issue affects Editors, so you will need to create another user account with the role of Editor.

In Access, switch the Posts (and Custom Post Types) back to being "Managed by Access".

Then log in using the Editor role.

Under the Posts menu, you will no longer see the "All posts" or "Add a new post" option, just the Categories link.

#2031107

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I can see the issue, it happens when the post type is managed by Toolset and WPML plugin activated. Let me debug the copy of your website and get back to you/

#2032347

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I was not able to find out the cause of this issue on my own. Let me check with our 2nd Tier for further assistance and get back to you.

#2038857

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Our 2nd Tier and other team members were not able to reproduce the issue with the copy of your website. Either the one directly taken from your website or another one from my copy. So, I migrated your site to our online platform and the issue was reproducible with different outcomes hidden link

When Posts are managed by Toolset, the editor is not able to create new regular or custom posts.
When Posts are not managed by Toolset, the editor can create regular posts and custom posts that are not managed by Toolset. The editor cannot create custom posts that are managed by Toolset.

I escalated this to our 2nd Tier, he'll investigate it and we'll get back to you as soon as possible.

#2050559

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Finally, we narrowed the issue down to an MU-plugin "disable-logged-out-plugin.php", once we deactivate it the Toolset Access control works as expected with WPML. You can check in this clone website hidden link

I wanted to check that on your website, so, I renamed the plugin to ".disable-logged-out-plugin.php" adding a dot at the beginning to prevent its execution, but that seems to crash the backend, and I can't access it anymore to test it further.

Please allow me FTP access to rename the plugin back and recover the website. Your next reply will be private to let you share credentials safely.

Please note that I will just recover the website, I won't investigate anything further with the plugin. This is custom code and is therefore out of the scope of the support.

#2050613

I had forgotten about that mu-plugin!
Thank you for figuring out that it was causing the issue.
I have removed it, and the back end is now accessible again.

Thanks again for your help.
Alan

#2050699

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Awesome Alan, I logged into your website and I can confirm it too. I am marking this ticket as resolved, you can reopen it in 12 hours if you still need assistance with this issue. Feel free to open a new ticket for any other question or request.