Skip Navigation

[Résolu] Woocommerce Views warning when installing Woo Bookings and Product Vendors

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem: The issue here is that the user is getting a warning about open_basedir whenever they activate the WooCommerce Bookings and WooCommerce Product Vendors when Woocommerce views is enabled.

Solution: The problem is that you server has an open_basedir restriction in place, and the WCV json file is being flagged because it’s not in one of the open paths.

I would recommend that you get in touch with your server team and ask them to modify the open_basedir server settings so this file can be opened.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Marqué : 

This topic contains 8 réponses, has 2 voix.

Last updated by PZ Il y a 1 an et 3 mois.

Assigned support staff: Shane.

Auteur
Publications
#1469389

PZ

After installing and activating WooCommerce Bookings and WooCommerce Product Vendors I get a warning about Woocommerce Views visible when adding new page or post.

I can share a screen of the warning in private message as it contains sensitive data and the path is strange.

#1469557

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

Thank you for getting in touch.

I've checked on the site using the credentials you've provided but i'm not seeing any strange messages. I've enabled the private fields so that you can provide me with the screenshots.

Thanks,
Shane

#1469609
#1469911

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

Would it be ok if I grabbed a full copy of the site using the duplicator plugin ?

If your site is larger than 500mb then I wouldn't be able to restore it from the all in one migration plugin.

Please let me know.
Thanks,
Shane

#1469921

PZ

It's about 400MB. So it's OK. You can use duplicator if you like (but AIOWPM makes only one file backup).

#1472481

PZ

Hi, is there any progress? If you need any more information or access please write.

#1473371

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

Currently restoring the backup to see what happens on my end.

Thanks,
Shane

#1473517

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

I've escalated your ticket to our 2nd tier supporters to see if they can replicate the issue from a copy of your site.

I tried to replicate the problem on the backup but im not able to see the issue there at all.

Will post any updates as soon as I get it.

Thanks,
Shane

#1473705

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

So I've gotten a response from our team and it seems to be a server issue.

The problem is that you searver has an open_basedir restriction in place, and the WCV json file is being flagged because it’s not in one of the open paths.

Could you get in touch with your server team and ask them to modify the open_basedir server settings so this file can be opened?

Thanks,
Shane

#1478013

PZ

My issue is resolved now. Thank you!