Skip Navigation

[Résolu] Views 2.8.1 upate problem

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem:

The issue here is that the user is getting the fatal error
An error of type E_PARSE was caused in line 66 of the file /XXX/wp-content/plugins/wp-views/application/controllers/cache/meta/manager.php.

After they updated their views plugin to 2.8.1
Solution:

Our team was aware of this issue and we've recently released our views version 2.8.1.1 which should resolve this issue for you.

https://toolset.com/account/downloads/

This support ticket is created Il y a 3 années et 4 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Marqué : ,

This topic contains 4 réponses, has 2 voix.

Last updated by tony Il y a 3 années et 4 mois.

Assigned support staff: Shane.

Auteur
Publications
#1245974

Whilst not critical to me right now, the update caused my site to stop working:

==================
Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In this case, WordPress caught an error with one of your plugins, Toolset Views.

An error of type E_PARSE was caused in line 66 of the file /home/milfordassociate/teesdalelocal.co.uk/wp-content/plugins/wp-views/application/controllers/cache/meta/manager.php. Error message: syntax error, unexpected ‘::’ (T_PAAMAYIM_NEKUDOTAYIM)
===================

All latest software is in use.

I hope this is of some help.

Tony

PHP 7.2.7

#1245993

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Tony,

Thank you for getting in touch.

Our development team is already aware of this issue and a solution will be made available in views version 2.8.1.1

This fix should be released shortly. You may mark this ticket as resolved once the release has been made and you've confirmed the fix

Thanks,
Shane

#1246508

Hi Shane

This site updated fine and is now working.

FYI it is using PHP 5.6

I did, however see another error on another site although that site appears to be functioning fine (as far as I can see).

I thought it best to report it just in case there is another glitch somewhere.

Kind regards
Tony

The error was:

First, visit your website (hidden link) and check for any visible issues. Next, visit the page where the error was caught (hidden link) and check for any visible issues.

Error Details
=============
An error of type E_ERROR was caused in line 16 of the file /home/tdswcorg/public_html/wp-content/plugins/types/vendor/toolset/toolset-common/inc/autoloaded/field/group.php. Error message: Interface 'OTGS\Toolset\Common\PublicAPI\CustomFieldGroup' not found

#1246591

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Tony,

Since the original issue of the ticket is resolved, our policy requires a new ticket be opened for separate issues.

This one I see is with our Types plugin so we will need to log it separately.

Please mark this as resolved and open a new ticket for the second issue.

Thanks,
Shane

#1246605

My issue is resolved now. Thank you!