Skip Navigation

[Résolu] Using Google API in combination with Oxygenbuilder

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 1 réponse, has 1 voix.

Last updated by DavidW2160 Il y a 2 mois et 3 semaines.

Auteur
Publications
#2128171

I have a Google Project with appropriate billing and two unrestricted API keys for maps. The API key works at dev.cottagegroveoregon.com but not on cottagegroveoregon.com. (I cloned the dev site to the production site, so they're identical). I'm using Oxygenbuilder, and I've cleared CSS Cache and resigned shortcodes, and there's no caching plugin. I'm using Oxygen's "google maps" module and assigned it the "address" field, and I know it's working because of the dev site. As I said, the sites are identical and all valid licenses (toolset, oxygenbuilder, etc.) have been added/verified as well.

This is the error I get: "Google Maps Platform rejected your request. You must use an API key to authenticate each request to Google Maps Platform APIs. For additional information, please refer to hidden link"

The API key is defined in the Toolset >> Settings >> Maps and validates correctly. Also, when I pull up an entry on the backend for editing,, the address map displays correctly. Also, the front page toolset view map (with markers) displays correctly. I have no idea where to look to solve this dilemma and don't know if it's a toolset, oxygenbuilder, database, or other issue.

#2128251

I suspect this is an Oxygenbuilder issue, not a Toolset issue, so I'm closing this ticket.