Skip Navigation

[Résolu] User registration form does not accept specific domain name

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem:

The issue here is that a specific email address isn't being validated while the other is when registering with a Toolset Form.. Example titi@cannesu.fr and titi@cannes.fr

Solution:

In order for the email to be valid the domain must also be valid. Toolset validation also checks to see if the email domain is valid. If it isn't then the verification of the email will fail.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 réponses, has 2 voix.

Last updated by Pat Il y a 10 mois et 4 semaines.

Assigned support staff: Shane.

Auteur
Publications
#1759537

Pat

Hello,

I have a forms that create a new user.
Works fine except when I try to create a new user with a specific domain name (ie : something like titi@cannesu.fr).
If I use another domain name (ie : titi@cannes.fr), it works. This is not a matter of duplicated email as the error message is :
Email Thanks to enter a valid email adress.

Is there some limitations or validations for domain names inside Froms?
Regards
Pat

#1759553

Pat

Another info : if I try to create a suer in the WordPress admin, then, I can use any of the domain names without limitation !!!
The issue is only present in the frontend.
Regards
Pat

#1759555

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pat,

Thank you for getting in touch.

The email field you are using is this the default email field for the user on wordpress ? Or are you creating a separate custom field for the user email ?

Please let me know the exact field so that I can know how to test this on my end.

Thanks,
Shane

#1759583

Pat

Hi Shane,

Thanks for helping.

Here is my field :
[cred_field field='user_email' class='form-control' output='bootstrap']

Regards
Pat

#1759585

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pat,

Thank you for the clarification.

I was able to replicate this issue on a fresh install and informed our 2nd tier supporters about it so that they can run a quick check as well and make a report to our development team.

As far as I can see the email is a valid one so it should validate correctly.

Thanks,
Shane

#1762519

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pat,

Our validation doesn't only check if the email is valid it also checks if the domain on the email is registered and actually valid.

If titi@cannesu.fr is a valid domain please let me know and we can take it from there.

Thanks,
Shane

#1762759

Pat

Hi Shane,

Thanks for the info.
I understand and will make what is needed to chose a valid domain name. I think this is something that should be described in the Toolset documentation.

Regards
Pat