Skip Navigation

[Fermé] Toolset plugin cannot connect to toolset

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Marqué : 

This topic contains 3 réponses, has 2 voix.

Last updated by Waqar Il y a 6 mois et 2 semaines.

Assigned support staff: Waqar.

Auteur
Publications
#2004539

I see this message in the WP back-end:

"Toolset needs to connect to its server to check for new releases and security updates. Something in the network or security settings is preventing this. Please allow outgoing communication to toolset.com to remove this notice."

Not sure what to do? I moved the website to a new server over the weekend so maybe something needs to be activated? I'm just not sure what?

#2004739

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

Have you activated the Toolset with a new site key generated for this new website address?
( ref: https://toolset.com/faq/how-to-install-and-register-toolset/#migrating-registration-to-a-different-domain )

Every Toolset site key works with the specific domain or base URL, which is why if the website is moved to a different one, you'll need to regenerate the site key for activation.

regards,
Waqar

#2009395

Hi Waqar
Thanks for the reply but you misunderstood. When I said I moved the website to a new server, I meant that this site was moved to a new server but the domain name remained the same. (ie the same license key). To be sure, after your email, I regenerated a new site key for this site and registered it with the site.

I am able to go into the commercial area of the "Add Plugin" area and unregister the site and then re-register and perform an update and activate on the Views plugin. However, although this is successful and works, I still get the same message as I noted above.

This is somewhat annoying in a minor way to be sure. However, since I have Toolset running on numerous other sites on other servers for other clients, I know this is not normal behavior or a normal message.

I was hoping that you might be able to suggest what might be the problem with the server so that I might inform my hosting service to rectify it and keep the Toolset updater happy. This problem seems to be unique with Toolset plugin updates and does not happen with other 3rd party plugins which cheerfully update without this message.

The apache server runs php 7.3. - You can see the php modules configured at /phpinfo.php

I would appreciate it if you could tell me if Toolset is missing something that prevents "outgoing communication" as mentioned in the Toolset error message after plugin update.

#2010167

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for writing back and sharing further details.

As you're able to register/activate Toolset and update the plugins, it means that the server is actually able to communicate and exchange information properly with Toolset.

That notification message can be a result of some temporary connection issue or some expired/unused transient. You can use any third-party plugin to clear the expired transients.
( ref: hidden link )

You can also visit the Toolset installer support page in the admin area to see if any additional errors or warnings are logged.
( {yourwebsite.com}/wp-admin/admin.php?page=otgs-installer-support )

Le sujet ‘[Fermé] Toolset plugin cannot connect to toolset’ est fermé à de nouvelles réponses.