Skip Navigation

[Résolu] recaptcha not working

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem: Client is trying to user reCaptcha but it is not working.

Solution: You need to enter two keys in the settings, and you must make sure you enter the correct key in each field.

Relevant Documentation: https://toolset.com/documentation/user-guides/creating-cred-forms/#form-spam-protection

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 0.48 hours from now. Thank you for your understanding.

This topic contains 2 réponses, has 2 voix.

Last updated by Sasank Il y a 2 années et 11 mois.

Assigned support staff: Nigel.

Auteur
Publications
#1071220

I generated API key for recaptcha multiple times but I am getting error when I place it in a form. It says "ERROR for site owner: Invalid site key". How do if fix it?

#1071354

Nigel
Supporter

Languages: Anglais (English ) Espagnol (Español )

Timezone: Europe/London (GMT+01:00)

Hi there

When you register with Google to user reCaptcha you get two keys, the site key and the secret key.

You then need to add these to Toolset > Settings > Forms, being careful to make sure you add the right key in the right place.

Then if you auto-generate your form and check the "Include reCaptcha field" option the reCaptcha field will be automatically added.

There is not much more to it than that. You need to be sure when you register for the API key that you use the correct domain for your site (you may need to add both site.com and hidden link if that is relevant in your case).

#1071360

I am sorry, I realized after opening ticket that I was entering the values in wrong fields..... forgot to update here.

Thanks for your reply