Skip Navigation

[Résolu] I seem to have a conflict between Views/Maps and Divi

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 réponses, has 2 voix.

Last updated by Tim Elliott Il y a 1 an et 12 mois.

Assigned support staff: Shane.

Auteur
Publications
#1367535

I have a site where the Divi builder stopped working properly. The builder layout is still showing but when I click to edit an item in the builder nothing happens.

I went through a process of turning off child theme and all plugins and then reactivating them on-by-one. It seems that the conflict occurs when Toolset Views and Maps are both activated at the same time.

So I when I have all plugins deactivated it works as expected.
Activate Types, Views and Maps - Divi builder doesn't work.
Deactivate either Views or Maps - works as expected.

At one point I also got an email through from the WP install saying:
"Your Site is Experiencing a Technical Issue"
"In this case, WordPress caught an error with one of your plugins, Toolset Views.
First, visit your website (hidden link) and check for any visible issues. Next, visit the page where the error was caught (hidden link) and check for any visible issues."

Any help much appreciated.

#1367637

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Tim,

Thank you for getting in touch.

It should be noted that toolset doesn't work with the latest divi experience builder.

You will need to disable this in divi new experience builder.

Click the Builder tab and then the advanced options tab. There you can find the option to enable or disable the latest Divi Builder Experience.

Also was this after an update? I know that there is an issue with divi where it conflicts with our maps plugin when both are importing the Google Maps API, so you can disable the google maps API in divi as well.

Please let me know if this helps.

Thanks,
Shane

#1368043

Hi Shane

Thanks for getting back to to me. I knew there was a problem where you can't add "Fields and Views" shortcodes to Divi blocks in the new builder using the button, but you can still add a shortcode manually and it should work. By the way, do you know if this is likely to be resolved soon?

In my case, the plugins are actually stopping me open the settings for a module due (it looks like) to some sort of admin-ajax conflict. So it's a slightly different behaviour from what I've experienced on other sites, hence the support request. Is there any sort of debug info I can look at to see what error is occurring? I've running tests on a development copy of the site so I can make any changes necessary.

Note that the old Divi builder does work OK, but that doesn't give access to all the settings in Divi modules.

#1368135

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Tim,

Usually these errors are shown in the Console of the browser when you visit the page that is giving the issue.

If you provide me with admin access to the site as well as a link to the backend page with the editor I can have a look at this for you.

However there is an issue that i've discovered with Divi with the new experience builder and Toolset maps where Divi doesn't disable the Maps API that they import when the new experience builder is active .

The private fields have been enabled for your next response.

Thanks,
Shane

#1368167

My issue is resolved now. Thank you!

It was to do with the admin page enqueuing the Google Maps API twice. Once for Toolset maps and once for Divi / Extra theme.

The particular version of Extra I was using was still enqueuing the Maps API even when it was turned off in the setting page.

Thanks for your help Shane. It wasn't a Toolset problem but you guys are always brilliant at supporting...