Skip Navigation

[Résolu] Front-end CRED form for uploading multiple images not working

This support ticket is created Il y a 6 années et 8 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 5 réponses, has 2 voix.

Last updated by davidS-53 Il y a 6 années et 8 mois.

Assisted by: Luo Yang.


I'm trying to allow users to upload/delete photos on the frontend using a cred form. However, once a photo has been uploaded, there's no way to remove it, or to swap to another. Is there a way to switch on a "delete" button for image upload fields/repeater fields? You'll see what I mean here: hidden link

Have a look at the images under "Work Photos" and the repeating text fields under "Testimonial Content"



Dear David,

Thanks for the details, I checked the problem URL you mentioned above, I can see there does exists the remove button in the left side of each image and text field, see screenshot:

Please let me know if you still need assistance for it. thanks

Screen Shot 2017-08-08 at 9.04.29 AM.png
Screen Shot 2017-08-08 at 9.01.44 AM.png


I don't actually see those features, as per my screenshot. I can see a div there called wpt-repetitive-controls, but there aren't any controls in it (see second screenshot)

Any ideas? Cheers.


It is strange, what I see is different from yours, it might be a problem of your browser, please try these:
1) Clear your browser cache
2) Change another browser and test again

Screen Shot 2017-08-08 at 2.18.37 PM.png

Yeah, cleared cache and still not there.

Tried in Chrome, Firefox and Safari- in each instance, no controls.

Here's something interesting though: looks like the issue is that there isn't any content being output in that button span. I can add text to it in inspector and the text i add becomes draggable.

Any ideas?


I actually managed to solve this accidentally. Was working on something else, and telling Toolset to load Bootstrap resulted in the control icons showing. So all sorted.

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.