Skip Navigation

[Gelöst] Retrieve authors profile picture URL (only)

Dieser Thread wurde gelöst. Hier ist eine Beschreibung des Problems und der Lösung.

Problem:

I need to render out the posts author profile picture to insert it into a JSON fragment.

Solution:

You can try attribute url='true', for example:

[types url='true' ... ][/types]

Relevant Documentation:

https://toolset.com/documentation/customizing-sites-using-php/functions/#image

This support ticket is created vor 2 Jahre, 10 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 2 Antworten, has 2 Stimmen.

Last updated by chrisH-10 vor 2 Jahre, 10 Monate.

Assigned support staff: Luo Yang.

Author
Artikel
#1449655

Tell us what you are trying to do?
I need to render out the posts author profile picture to insert it into a JSON fragment.

Is there any documentation that you are following?
I had found [types usermeta='profile-picture' title='%%TITLE%%' alt='%%ALT%%' size='thumbnail' proportional='false' user_is_author='true'][/types] but I can't figure out how to make it just give me the URL to the image.

Is there a similar example that we can see?
Nope

What is the link to your site?
Not really applicable but the fragment is on hidden link

#1449971

Luo Yang
Supporter

Languages: Englisch (English ) Vereinfachtes Chinesisch (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

You can try attribute url='true', for example:

[types url='true' ... ][/types]

More help:
https://toolset.com/documentation/customizing-sites-using-php/functions/#image
url:
'false'(default) | 'true'
true=output the url of the image instead of the html img tag.

#1451113

My issue is resolved now. Thank you!