Skip Navigation

[Gelöst] Very slow query

This support ticket is created vor 2 Jahre, 3 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

This topic contains 3 Antworten, has 2 Stimmen.

Last updated by Minesh vor 2 Jahre, 3 Monate.

Assisted by: Minesh.

Captura de pantalla 2021-08-26 183310.jpg


I have a problem with the page loading time.: hidden link
It takes almost 8 seconds to load.
Query monitor shows that I have 11 slow queries. I have installed Litespeed cache.
This page will be updated, approximately once a week.

Any suggestions on how can I improve the loading time? Thanks!



Languages: Englisch (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

view's load time is depend on the server resources like CPU, ram as well as hosting.

I see you are using the nested views and the amount of data you are retrieving seems causing the issue as there are hundreds of posts are listed using the nested views.

Please check the following Doc that may help you:


I have tried to fix the problem as follows:

Force to cache the 3 nested views with the attribute cached="force":

[wpv-view name="secciones-carta" cached="force"]
--[wpv-view name="contenido-de-cada-seccion-de-la-carta" cached="force"]
----[wpv-view name="alergenos-del-plato" cached="force"]

Now the three views are cached on server and the page where I display de views load fast.

But the problem comes when I modify something using a front end form to update a post. The view does not display the changes.

What can I do to clean the cache after update any post in the view ?




Languages: Englisch (English )

Timezone: Asia/Kolkata (GMT+05:30)

The value for cache attribute for the view's is either On or Off as you can see with our Docs:

I'm not sure from where you find the value cached="force". By default view's cache attribute value is On.

Here is how you can enable-disable cache using the filter hook: wpv_filter_disable_caching

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.