Skip Navigation

[Resolved] Some block settings are no longer work after a simple page refresh

This support ticket is created 3 years, 7 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

This topic contains 22 replies, has 3 voices.

Last updated by Minesh 3 years, 5 months ago.

Assigned support staff: Minesh.

Author
Posts
#1512971

I have disabled all of the plugins and caching. I added everything to this "Articole recente - Home" toolset template, and it's visible on /carte/ page.

#1512975

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Can you please send me FPT access details and I will check this further.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I have set the next reply to private which means only you and I have access to it.

#1512993
#1514433

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

So, I've to debug each and every element block you've added to your content template here:
=> hidden link

I see the view block you added to right column of your grid where you added to conditional blocks I see again you did not add the conditional statements properly. Please check the following screenshot:
=> hidden link

So, I've corrected the conditional statements for all 19 conditional blocks.

Then - the grid block of the right column where you added the block view, I see that the last conditional block you added with the button was not the proper block, it should contain the conditional with the image block. I've added it and now I can see the proper image at least even when I refresh the page:
=> hidden link

To adjust the height/width for the container to display the image properly you should adjust the properties of the container block of the last conditional block that is added to your right column. Please check the screenshot:
=> hidden link

whenever you add block please make sure you added it correctly, it was really hard to debug the hundreds of conditional statements with blocks and to debug each conditional statement.

#1514519

Hello Mines,
I really appreciate your help with the conditional blocks and that you have spent time with them... but the main problem is still there. Setting up a certain "design" with the grid block or setting some dimension for an image through the image block is worthless because it breaks after the first refresh of the browser. Lets assume that now we have fixed the conditional blocs, I'm using a really simple and good theme "Astra", I have disabled all of the plugins… I’m asking…

Why not keep the design that I made with Toolset Blocks? That should look like this: hidden link
Please check this video: hidden link

#1514591

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Can you please check on frontend now: hidden link

Can you confirm it's working as expected even when you refresh the page?

#1514597

Yes, it works as expected!! How did you fix it?

#1514623

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

glad to know, finally it works.

So - I've added the following code to disable the view's cache at "Custom Code" section offered by Toolset:
=> hidden link

add_filter('wpv_filter_disable_caching', 'func_filter_disable_views_cache', 10, 2);
function func_filter_disable_views_cache($status, $view_id){
   if($view_id == 4024 or $view_id == 4324) {
      $status = true;
   }
 
   return $status;
}

Gald to help and I've duplicator copy of your site, I will debug further for cache issue and if I am able to reproduce it I will escalate it. You are welcome to resolve this ticket. Thank you for your patience and co-ordination. I really appreciate it.

#1514627

My issue is resolved now. Thank you!

New threads created by Beda and linked to this one are listed below:

https://toolset.com/forums/topic/split-some-block-settings-are-no-longer-work-after-a-simple-page-refresh/

#1520547

Hello Robert

I was debugging the issue you report in several attempts and there is no step that leads to that issue yet, so we cannot solve anything either, we need to know why what happens first.

Your setup is unusual, and you can if you prefer just use Minesh's solution, but in all honesty, I would suggest some amendments in the way you display data, and I would also like to find the reason for this issue so to have steps, provide them to the developers, and let them fix it.

But for that, I need steps that lead to this issue.
I have even tried to rebuild a view like yours in the very duplicate, and could not see the same issue.
Now, I also see many PHP errors in the error log and several cache mechanisms are used. All of this can contribute to the error.

Can you eventually provide me with more details, how this happened, when it started, how we can replicate it?

Also note that when you use Views with other cache mechanisms, you will get conflicts.
The solution here would be to disable either or both, which Mineshs's solution does.
I am however not sure that is the cause of the issue.
It could be anything, at this moment, I also found that simply disabling Astra theme solved the issue

I am happy to pursue this until we have a solution but would need more details and information on it for replication.
If you can help us, could you follow up here?
https://toolset.com/forums/topic/split-some-block-settings-are-no-longer-work-after-a-simple-page-refresh/

Thanks!!

#1584653

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I would like to inform you that the fix for this issue has been shipped with the Blocks/Views latest plugin version. Please feel free to update it.