Skip Navigation

[Gelöst] Marker and coordinates not displayed

This support ticket is created vor 8 Jahre, 1 Monat. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- - 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00
- - - - - - -

Supporter timezone: Asia/Ho_Chi_Minh (GMT+07:00)

This topic contains 8 Antworten, has 2 Stimmen.

Last updated by Beda vor 8 Jahre, 1 Monat.

Assisted by: Beda.


I am trying to: display address in template with coordinates

I visited this URL: hidden link

I expected to see: map and coordinates

Instead, I got: no map, no coordinates, no marker, just address


To Display data on google Maps with Toolset Maps, you need to follow this instructions:

You will create Posts with a Custom Field "Address" and add Addresses to this Field, then save the Post.

After, in a View Loop or a Content Template (if a single post) you need to add the ShortCode for the Map, and the Marker.

The Views GUI will ask you to enter all required details, such as from which field to get the Address and with what marker to display it.

You will also need to register a Google API Key as otherwise your Map will most probably not dipole the data after some loads of the map, due to Google Map API Restrictions:

Please let me know if you have further questions regarding the issue mentioned in this Thread

Thank you for your patience.


Everything has been done according instructions. Could you please check yourself. I can send you login details.


Does the issue also persist with a WordPress Default Theme and NO Plugins BUT the Toolset Plugins?

If not, could you then re-enable the Plugins one after the other, and check the issue each time you enable a plugin?
Please report me when the issue comes back
It might also be due to the Theme.
Please do reactivate your Theme only after you are sure the issue isn't coming form a 3rd Party Plugin.

If this doesn't help I would need to request temporary access (WP-Admin and FTP) to your site
- preferably to a test site where the problem has been replicated if possible -
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would, if possible, need access to a site where only a minimal set of Plugins and a default theme is active.
This to avoid eventual compatibility issues with other software.

✙ I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site.
This is also a reason the backup is really important

✙ Please add the Links to:

- The Views Edit Screen where you display the Map

- The Page/Post where you insert the View

- The corresponding Front End Page/Screen

- Corresponding Posts with Addresses.

Please could you provide me the additional Infos, and as well permit me to perform the required steps?

Thank you for your patience.


There are errors on your site.

Warning: deg2rad() expects parameter 1 to be double, string given in [...]/wp-content/themes/searchbuzz/functions.php on line 306

Single Ad's do not use a Content Template or any Layout crated by Toolset but do display multiple Maps (not sure where you add them)

Additionally you seem to load custom styles of Google Maps, not what we deliver with Toolset Maps Plugin.

Then you have 2 Address fields, pleas decide which one is to use on Maps for Ads - as you gave them the same Name, you are not able to see the difference in the GUI itself.

If you disable all Plugins but Toolset and use the other theme you have on site (Toolset Bootstrap) you see what I mean, the Map is then working

The Marker is possibly not showing because the limits of google are exhausted.

Can you try to regenerate your API key and save it again in the according settings under Views > Toolset Maps?

Please also change the doubled Address Fields so you can safely differentiate them

Please let me know if the above solution works for you, I look forward to your reply!

Thank you for your patience.


Error is because function cannot get coordinates.

Maps are added via template single-ad.php

customs styles or any other plugin do not have any influence. tested.

second address deleted.

on other theme I cannot even display single ad page. Its just empty. please check.

this is a test site and it cannot be exhausted with just few views. Same problem on live site with proper key generated.

as you can see here "test-site"/ad/toolset-test/ it does not show coordinates and marker on the map. and there is wrong author for post.

Bildschirmfoto 2016-03-14 um 17.21.56.png
Bildschirmfoto 2016-03-14 um 17.24.00.png

It would be good that you first update your Toolset to it's latest version. Can you do this please?

❌ Be sure to backup your database first before you proceed! ❌
⌥ You can use a plugin for this if you like.
I often use the Duplicator plugin for this purpose.

The author is not incorrect.

I am user "temp" and this is what you see on the post Admin screen and also on the Content template I crated for this porpoise
hidden link

Also the Single Ad is very well visible also with theme Bootstrap

Since you use non-supported approaches in the original Content template I can not debug it there
(Such as ShortCode as CSS class)

Then you nest Toolset ShortCodes in 3rd Party ShortCodes, which I can not debug.

You want to register your 3rd party ShortCodes under Views > Settings > Compatibility > 3rd Party ShortCodes first, and then this might work.

But WordPress is not supporting this, and that is why you need to register those first for the Views do_shortcode() function first (it's our specific Toolset ShortCode parser)

Then, you need to pay attention to the Apostrophes in your Nested ShortCodes and if you use them as Attributes for HTML.
WordPress is not recommending this:

Also the additional Address Field still exists, it's not deleted.
By now it's only removed from Types Control.
To delete, please head to admin.php?page=wpcf-custom-fields-control

This is elaborated here: > blue disclaimer

I am requesting a Company Google API Key to test on your site to see if that is the issue.

Please meanwhile try all above suggested steps and issue solving processes.

Please don't hesitate to inform me in case the issue persists

Thank you for your patience.



did all the steps. Problem still persist.

Created new content template from scratch - aaa test single page. Assigned properly - same problem.

In admin - it shows coordinates and map properly. In frontend - nothing.

Please help

Map Issue.png

As suspected changing the API Key to our companies API Key solved the issue.

Additionally I played a bit with the code in the Content Template to reduce our Debugging to the topic of this thread.

1. Map correctly displayed with marker
2. Address correctly displayed as text
3. Lat/Long correctly displayed
4. Author is "Temp" which is me.


1. Front End ad/toolset-test/
2. Content Template wp-admin/admin.php?page=ct-editor&ct_id=4165&action=edit
3. Ad wp-admin/post.php?post=4152&action=edit

Tested with both Themes of Toolset.

Please review your API Key, it is probably not set up correctly, as adding our Key solved the issue.
I removed our key and added your key back.

Thank you

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.