Skip Navigation

[Gelöst] Link icon on wysiwyg not working

This support ticket is created vor 5 Monate, 1 Woche. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 5 Antworten, has 2 Stimmen.

Last updated by Waqar vor 3 Monate, 1 Woche.

Assisted by: Waqar.

Author
Artikel
#2645157

Hi

The wysiwyg link icon isn't working. All the others are fine.

I switched to a default theme
I deactivated plugins
I downgraded the site's PHP version

All the Toolset plugins are up to date Also, not sure if it's related, but I managed to install OTGS but couldn't activate it)

Nothing has worked, so I can only assume that the issue is with the Toolset plugin(s)

Thanks for your help

Nathalie

#2645327

Waqar
Supporter

Languages: Englisch (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Nathalie,

Thank you for contacting us and I'd be happy to assist.

I've performed some tests on my website, but couldn't reproduce this.

Do you see any error or warning in the browser console or in the server's error log?
( ref: https://wordpress.org/documentation/article/debugging-in-wordpress/ )

In case there are no errors or warnings, you're welcome to share temporary admin login details, along with the exact steps to see the issue.

Note: Your next reply will be private and it is recommended to make a complete backup copy before sharing the access details.

regards,
Waqar

#2658085

When you click the "link" button on the WYSIWYG and scroll down, you will see what happens - below the site footer

Nathalie

#2658725

Waqar
Supporter

Languages: Englisch (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the access details.

During troubleshooting, I noticed that the following URL that WordPress uses to load its default styles and scripts, is resulting in '404 not found' error:


{yourwebsite.com}/wp-admin/load-styles.php?c=1&dir=ltr&load%5Bchunk_0%5D=editor-buttons&ver=545737aad7293db13a57381a13a71392

And as those default styles and scripts are not loaded on the page, the link button the in WYSIWYG editor, doesn't behave as expected.
( you may also experience other style and functional abnormalities as well )

Looks like your security plugin or server's policy are blocking these styles and scripts. Can you please test this with the 'Wordfence' plugin disabled? It would also be a good idea to consult your hosting support team to see if there is some extra layer of security, which can interfere with this.

#2663807

Hi Waqar

In case somebody has the issue:
Something was out of sync between the web server configuration, wp-config.php and WP Toolkit. I resolved the issue by detaching the site from Wp Toolkit.

Many thanks for your help because it directed me to the solution. It took a while, but it's all sorted now : )

Nathalie

#2663943

Waqar
Supporter

Languages: Englisch (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for the update and glad this is sorted now 🙂

Appreciate you shared your findings here and it will help other users too.

Feel free to mark this ticket as resolved and start a new one for each new questions or concerns.

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.