Skip Navigation

[Gelöst] Layouts freezing bug after update to wordpress 5.6

This support ticket is created vor 3 Jahre, 3 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 6 Antworten, has 2 Stimmen.

Last updated by erikd-6 vor 3 Jahre, 3 Monate.

Assisted by: Luo Yang.

javascript error when using Layouts with WordPress 5.6.png

I am trying to: edit a page in the content layouts editor

Link to a page where the issue can be seen: any page on any site with layouts plugin and wordpress 5.6

In Edit page I click on the Content Layouts editor button (Edit with layouts). I make a new row. I select a number of cells and insert a Visual editor. I write something in the visual editor and create. Then I select another number of cells. Now the page freezes with a dark half transparent overlay.

So what is happening is that when I'm inside the Layouts editor and I have made a new cell if I then make a second cell the interface freezes at the point where the popup with all the cells should show.

This error is very consistent and happens in every site where I try it - and I have a lot of sites built with Layouts.

I opened a console window while testing this error and saw a Javascript error is thrown at the moment the second number of cells is selected. This indicates this is a Javascript error, possibly due to an incompatibility of Layouts with the new jQuery database that has been introduced in the WordPress 5.6 update. See the screenshot I added.



The problem you mentioned above is abnormal, please check these:
1) In case it is a compatibility problem, please deactivate all other plugins, and switch to wordpress default theme 2021, deactivate all custom PHP/JS code snippets, and test again

2) Also check if there is any PHP error in your website:

3) If the problem still persists, please provide database dump file(ZIP file) of your website, you can put the package files in your own google drive disk, share the link only, also point out the problem page URL and layout URL, I need to test and debug it in my localhost, thanks


I can see the problem with your duplicator package, then I have tried it with a fresh WP installation + the latest version of Toolset plugin + same Toolset Starter Theme file from your package files, it works fine, see my screenshot layout.JPG

So it might be an exception of your website, do you have any clue to reproduce the same problem in fresh WP installation?

Layouts javascript error with details.png

It seems good news that you managed to stop the issue with a fresh install. However, as I said in my opening post, this is not an anomaly on one site; this happens after the WordPress 5.6 update on almost every site I have built with the Toolset Starter Theme and Layouts. It would be an impossible job to rebuilt all those sites on fresh installs, besides, that's how they were buuilt in the first place.

The errors reported in the console are in the Layouts plugin, combined with jQuery. Is there no clue for you?

I also build sites with the Minimax theme by Beda, which is even a much more simple theme. Here I have the same issues on a fresh WP install I built after the 5.6 update.

What are the settings you have on your test site for loading Bootstrap?


The problem is related with the parent layout "Header and Footer", I can reproduce the problem, and have escalate this issue, will update here if there is anything news.


Here is the feedback from our developers:
It is fixed in next version of Toolset Layouts plugin 2.6.8, which is under QA status.

And our developers provide a patch for it, you can download it here:
hidden link

Based on the latest Layouts stable version, take the patch package and unzip it, upload the file it contains to replace this file with the same name, under /wp-content/plugins/layouts/inc/gui/editor/js/ddl-tree-filter.js.

You can test it, and feedback if if it is fixed, thanks


I tested the patch on several sites and it solved the issue. Thanks!

My issue is resolved now. Thank you!

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.