Skip Navigation

[Gelöst] I need the numeral field to accept commas (it’s fine if it sanitizes it)

Dieser Thread wurde gelöst. Hier ist eine Beschreibung des Problems und der Lösung.

Problem:

The issue here is that the user wanted to know if it is possible to send a first reply on our forums as a private message.

Solution:

Unfortunately no this is not possible. A private field can only be enabled by a member of our support team when requested.

This support ticket is created vor 3 Jahre, 2 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 8 Antworten, has 3 Stimmen.

Last updated by Bob Dowdy vor 3 Jahre, 2 Monate.

Assigned support staff: Shane.

Author
Artikel
#1212067

Tell us what you are trying to do?
Allow Property Agents to enter the price of properties and square footage (post type fields set to 'numeral') in regular formats. It's fine if it sanitizes the number as soon as they enter it. This will allow Agents to cut and paste more easily.

Is there any documentation that you are following?
None

Is there a similar example that we can see?
None

What is the link to your site?
hidden link

#1212110

This is not possible.
The Number field will accept only numeric data.

To add other values, like dot, comma or semicolons, you need to use a single line field.

If you wish the number field to also accept other values or even let you customize with a regex what it accepts, you would need to suggest this here https://toolset.com/home/contact-us/suggest-a-new-feature-for-toolset/

PS; I removed the private data (access to the site) from the post as that is a public post.
If you require to add private data you can do so when opening tickets (choose "make reply private) or require such private reply later from Support.

Thanks!

#1214227

How do you mark a post as private?
I just started a new ticket to check - the option is not there

#1214237

Shane
Supporter

Languages: Englisch (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Bob,

There should be an option for it if you select the option " Something is not doing what I expect it to" when creating a new ticket.

Thanks,
Shane

#1214258
Screen Shot 2019-03-14 at 9.28.13 AM.png
Screen Shot 2019-03-14 at 9.28.24 AM.png
Screen Shot 2019-03-14 at 9.28.31 AM.png

Shane,

I think something may be wrong with the ticketing system. When I select that option I do not get a "mark as private" option. Attaching screenshots.

#1214274

Shane
Supporter

Languages: Englisch (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Bob,

You need to click on the button "I want to grant access" button.

This should provide you with the fields.

Thanks,
Shane

#1214278
Screen Shot 2019-03-14 at 9.42.43 AM.png

Hmm, I still don't see where I can mark the message as private.

Is there a way to mark a message as private without entering admin login credentials?

#1214405

Shane
Supporter

Languages: Englisch (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Bob,

Perhaps i'm a bit confused.

You can provide private information with the credentials etc, however your first initial reply to open the ticket cannot be private.

However we as supporters can mark your next response as private, but the initial opening of the ticket cannot be private since it is a public forum.

Thanks,
Shane

#1214437

Ahh, I see - no, I am the one confused 🙂 I understand now.

Thanks for you help, Shane and Beda.