Skip Navigation

[Gelöst] Views won't randomize results

This support ticket is created vor 7 Jahre. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 3 Antworten, has 2 Stimmen.

Last updated by Marisa vor 7 Jahre.

Assigned support staff: Luo Yang.


I am trying to:
Randomize the Miniature Product View. It should show 4 of the 8 products, but shows the same 4 products even though I have random selected as the view order. It shows the same 4 minus the one whose page it's on.

I visited this URL:
hidden link

I expected to see:
Different products on each product page and on page refresh

Instead, I got:
The same first four - lone star, settlement harbor, brazos, ponderosa (minus the smokey bear it's on). In the very same order, too.


adding a screenshot


Luo Yang

Languages: Englisch (English ) Vereinfachtes Chinesisch (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear Marisa,

I can not duplicate same problem, please check these:
1) you are using the latest version of Views
2) there isn't cache plugin or something else similar, you can try deactivate other plugins and switch to wordpress default theme, and test again.


I found the issue.

Post Types Reorder has a setting that uses Menu > Desc to over ride all queries if you check it. I unchecked it so I could choose the order per view. My apologies. 🙁