Skip Navigation

[Gelöst] Views doesn’t work when accessed directly via copy/pasted URL with parameters

Dieser Thread wurde gelöst. Hier ist eine Beschreibung des Problems und der Lösung.

Problem:

How to use legacy editor in Toolset Blocks plugin?

Solution:

You can follow our document to enable legacy editor:

https://toolset.com/course-lesson/enabling-legacy-version-of-toolset-views/

so you can edit Toolset Views and WordPress Archive with classic editor.

Relevant Documentation:

This support ticket is created vor 7 Monate, 2 Wochen. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 6 Antworten, has 2 Stimmen.

Last updated by ashleighP vor 6 Monate, 3 Wochen.

Assigned support staff: Luo Yang.

Author
Artikel
#2385185
how it looks when I paste the identical url into a new tab.png
how it looks when I use the form and check the on sale box.png

I am trying to: Create a direct link to the search results of a parametric view. I have the view set up to output as URL parameter. I copied the URL and added it to my menu but when I use the link I get the nothing found message.

Link to a page where the issue can be seen: hidden link

I expected to see: Products, filtered to show only the ones on sale

Instead, I got: error message

The plugins I use are up to date. It worked when I briefly installed Toolset Blocks and it auto deactivated Toolset Views, but since I use the classic editor and not the block editor, and I could no longer access my views, I removed the Blocks plugin. I don't know why it wouldn't be working in Views.

#2385255

Luo Yang
Supporter

Languages: Englisch (English ) Vereinfachtes Chinesisch (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

I assume it works fine when you use Toolset Blocks plugin.

If it is, please try these:
1) Install and activate the latest version of Toolset Blocks + Toolset WooCommerce Blocks plugins, you can download them here:
https://toolset.com/account/downloads/

2) Follow our document to enable legacy editor:
https://toolset.com/course-lesson/enabling-legacy-version-of-toolset-views/
so you can edit Toolset Views and WordPress Archive with classic editor, and test again

#2385751

Yes, that seems to be working fine, and I can access all my Views again. Thanks.

#2412203

Luo Yang
Supporter

Languages: Englisch (English ) Vereinfachtes Chinesisch (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I assume you are going to display onsale product posts, which product post is onsale status? I did not find any product post with sale price in your website.

#2412507
Screen Shot 2022-07-06 at 12.57.27 PM.png

Everything in the custom artwork category is marked on sale, in addition to a few other products.

#2413007

Luo Yang
Supporter

Languages: Englisch (English ) Vereinfachtes Chinesisch (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Please try these:
Edit the Toolset WordPress Archive "Shop — Archive":
hidden link
In section "Query Filter", remove the filter "on sale status", and test again.

#2415715

Seems to be working with that change, thank you.