I am still using the legacy "Toolset Layouts" and "Content Templates" for many of my sites. I have a site that I built and I have a specific layout for a taxonomy archive page that uses a Sorting Filter for Woocomerce Products.
It's strange... the Sorting Filter works fine on one taxonomy archive page like this.... versteckter Link
But on another taxonomy archive page it seems to break.. like this.... versteckter Link. I can see an error in the console...
Uncaught TypeError: jQuery(...).live is not a function at (index):3215:88
/wp-admin/admin-ajax.php:1 Failed to load resource: the server responded with a status of 502 ()
I have no idea how this can work on one page and not work on the next. Is this a bug?
Hi Ned,
Thank you for getting in touch.
In both cases i'm not seeing any breaking of the Layout when the sorting filter is applied.
Can you perhaps record a short demonstration video of the issue.
Thanks,
Shane
Hi Shane.... no the layout isn't breaking. Sorry for any confusion.
If you go to the first link.. and then try to sort by Price (for example), then the sorting works fine and all products get sorted properly without issue.
If you go to the second link.. and then try to sort by Price (for example), then the sorting doesn't work and I see the error in the console.
Hi Ned,
Based on what I see the list appears to be sorted correctly to me when i've applied the sorting option. See Screenshot.
I'm not able to spot the immediate issue. Perhaps there is something i'm missing?
Thanks,
Shane
Hmmm.. interesting.
I went to the problematic page in a new browser and didn't log in as an administrator (pretended to be a normal visitor)... and the sorting seems to work normally.
Strange. It doesn't seem to work that way when I am logged in as an admin.
No worries though. I can deal with this.
Thanks!