Skip Navigation

[Gelöst] Server timeout while updating post

This support ticket is created vor 2 Jahre, 10 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 14:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Jamaica (GMT-05:00)

This topic contains 12 Antworten, has 2 Stimmen.

Last updated by zoeS vor 2 Jahre, 10 Monate.

Assigned support staff: Shane.

Author
Artikel
#1455859

A new problem has just appeared where updating one of my post types (houses) is causing a server timeout. It only happens with this one post type, and only in the default language. I have been chatting to WPML support already and we established that no PHP errors are being produced and that WPML is not the source of the problem.

I have tried disabling all plug-ins, except wp-types (since the posts in question would then disappear), and the problem persists.

I ran my weekly plug-in updates yesterday, but can't remember if Types was one of those plug-ins that was updated.

#1456375

Shane
Supporter

Languages: Englisch (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Zoe,

Thank you for getting in touch.

Given that the server is timing it it could be an issue with the Apache. What i would recommend you do is to try finding the Apache server logs on the server and send it to me or contact the hosting company and have them look at the logs to see what is wrong.

Once you have done this please let me know and we can take it from there.

Thanks,
Shane

#1456761

Hi Shane, thank you for your reply. I have been in contact with the hosts, and they have just sent back a few of the timeout errors that I was already aware of. They all look something like this:

[Mon Jan 13 10:46:11.298405 2020] [:warn] [pid 26105] [client xxxxxx]Timeout waiting for output from CGI script /xxxx/xxxx/public_html/wp-admin/post.php, referer: hidden link

They say they have also increased the dynamic timeout limit to 300 seconds, but it should never have been taking more than a couple of seconds to save a post anyway, so I don't think that will resolve the problem.

They also noted that there were some slow database queries and suggested I optimise the database. But the problem is very specific: it is only when trying to update any post of this particular post type that the problem occurs. It is updated, but takes more than a minute to do so. Otherwise, everything seems to be running perfectly.

#1458021

Shane
Supporter

Languages: Englisch (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Zoe,

Mind providing me with admin access to the site so that I can have a look ?

Perhaps experiencing the issue first hand might reveal something to me.

I also may need to install the duplicator plugin to grab a copy of the site if thats ok with you.

The private fields have been enabled for your next response.

Thanks,
Shane

#1460699

Hi Shane, I can see you're really busy, but have you any updates please? I'm under a lot of pressure here from a client who still can't update their site after 3 days.

#1460701

Shane
Supporter

Languages: Englisch (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Zoe,

I've escalated this to our 2nd tier supporters for further debugging to check what they can find.

I'm able to replicate the same issue in the copy of your website.

#1460705

Great, thank you so much!

#1460715

If it's any help, I installed the Duplicator package on MAMP, also replicated the problem, and think it is related to the "property media" custom fields as the problem went away when those were disabled. Beyond that, I still have no idea.

#1462225

Shane
Supporter

Languages: Englisch (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Zoe,

Could you try something for you me. Could you disable the property media custom fields and add a new set of image fields to your post. Then enable the block editor for the CPT and then try updating.

Once you have done this please let me know.
Thanks,
Shane

#1462307

Hi Shane,

Ok I did that and even without actually adding any images to the new image fields, the save time went from 4 seconds to 15+. With the block editor enabled, the post itself seemed to save immediately, but the new image fields carried on spinning for much longer. With 12 images added to the new custom fields, the save time is as bad as with the original property media fields.

Thanks
Zoë

#1468707

Hi Shane, has there been any update? I submitted this support ticket a week ago now. Is there maybe somebody else on the support team who has more time to help? I have always had really good support here before, but I can't wait over a week to resolve an important client issue.

#1469387

Shane
Supporter

Languages: Englisch (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Zoe,

Our 2nd tier supporters have identified the issue and have reported it to our development team.

Currently i'm not seeing any update on that escalated ticket but our 2nd tier supporters have definitely submitted the issue to the development team.

Thanks,
Shane

#1474843

Hi Shane, I think I have solved the problem. The database was in a mess with thousands of duplicate attachments, so by removing the majority of those and using a plug-in to clean up the database, things are now working reasonably well. How it got in to that state is another question, but the site is a complex combination of WP All Import, WPML and Types, and there is a lot that can and does go wrong from time to time.