Skip Navigation

[Gelöst] refresh after filtering

This support ticket is created vor 6 Monate, 1 Woche. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

This topic contains 6 Antworten, has 2 Stimmen.

Last updated by Dido vor 6 Monate, 1 Woche.

Assigned support staff: Minesh.

Author
Artikel
#2376157

Hi,

I am working on a website that I took over from a colleague. I have a problem with this page:
hidden link

After filtering, I get a blank page. What can be the reason?

#2376209

Minesh
Supporter

Languages: Englisch (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

I can see the issue you mentioned with the problem URL you shared.

Can you please check the view is configured correctly and added correctly with search form and search result.

Are you using any optimization plugin, if yes, could you please try to disable any cache or optimization plugin and check if that help you to resolve your issue.

if none of the above steps helps, what if you set your view to filter results when you click on search button, does that works?

#2376355

Hi Minesh,

it works now, but without Ajax and with the search button.
unfortunatelly the location on the map is not working anymore.

update: it looks like the category search is different from the maps search.
category search goes automaticly and gives a clean url, but maps does not.

#2376363

Minesh
Supporter

Languages: Englisch (English )

Timezone: Asia/Kolkata (GMT+05:30)

You say location is not working, have you registered the proper Google Map API key?
=> https://toolset.com/course-lesson/creating-a-maps-api-key/#creating-an-api-key-for-google-maps

I can see on browser's console the following error:

You must use an API key to authenticate each request to Google Maps Platform APIs. For additional information, please refer to <em><u>hidden link</u></em> For more information on authentication and Google Maps JavaScript API services please see: <em><u>hidden link</u></em>
#2376427
api.JPG

My client made sure the API was working. a few hours ago, she changed it.
Yesterday we had an error but despite of that, the map worked on desktops.

I'll ask my client if she activated all the API's we need for this.

#2376471

Minesh
Supporter

Languages: Englisch (English )

Timezone: Asia/Kolkata (GMT+05:30)

ok and please make sure if you are using any page builder and that page builder supports google map, you should disable the google map API with your page builder to avoid conflict.

#2376515

My issue is resolved now. Thank you! The problem was, I removed the query code in the Query section, before I duplicated the original view for the test page. Now all is working fine.