Skip Navigation

[Gelöst] old custom field value in dropdown

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 Antworten, has 2 Stimmen.

Last updated by Kristin vor 3 Jahre, 2 Monate.

Author
Artikel
#952474
Screen Shot 2018-07-20 at 4.30.58 PM .png

I am trying to:
filter by a custom field for facility city

Link to a page where the issue can be seen:
hidden link

I expected to see:
in the dropdown, i expect to see only cities listed that have posts associated with them

Instead, I got:
an incorrect value of Brentwood 94513 in the dropdown - this has since been changed just to Brentwood, and selecting it returns no results.

#952813

The is most likely a field, that is still existing in the database for the older posts with that value.
I tried to figure out what field it is, but when I try to edit a post of kind facility I get a white page:
hidden link

But I found it here.
hidden link

It's indeed a Single Line field originally so if you edit or save that in a post it means you can add any value.
Old values aren't updated if you create new posts.
You need to go and edit those old posts and then that option should disappear from the filter.

Once that is done, I also suggest to update the Filters in the View (you seem to us AJAX) to:
Let me choose individual settings manually
==> Show only available options for each input > Hide or Disable.

If all that does not help, can you try if updating Toolset, and making sure no other plugin interferes?

I do not see the database - but I am quite sure there is some post with that value, I mean, a field with that value, which is orphaned and hence still "present".

#1005025

Thanks for following up. We did a serialized search and replace in the DB to remove this and we're all set.

🙂