Skip Navigation

[Geschlossen] New content is not appearing

This support ticket is created vor 2 Jahre, 9 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Heute stehen keine Supporter zur Arbeit im Werkzeugsatz-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

Sun Mon Tue Wed Thu Fri Sat
9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 - - 9:00 – 13:00
14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 - - 14:00 – 18:00

Supporter timezone: Africa/Casablanca (GMT+01:00)

Dieses Thema enthält 12 Antworten, hat 3 Stimmen.

Zuletzt aktualisiert von Jamal vor 2 Jahre, 8 Monate.

Assistiert von: Jamal.


I am trying to:
- Added a new item (custom content type). It's published. Detail page can be viewed at versteckter Link
- On the listing page versteckter Link will show "Found 21 results" which is correct.
- The article should show on the second page. It's alpha sort by title.
- Once you go to the second page it will show "Found 20 results"

Things I've tried:
- All plugins are up to date.
- Cleared server cache.
- Cleared Toolset > Settings > Front end content > Clear custom fields cache now
- Clicked Clean cache for that particular view
- Change the sort order to have it show on the first page. It does not show up.
- Set display items per page to 50 so there is no pagination. This content item then shows up but that's not what we want. We want to paginate at 12.


Also if you use the filter Prevention > Board that article should show up but does not.



Sprachen: Englisch (English )

Zeitzone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

This is really strange.

First of all - After checking to debug the information you shared with us, I found that you are using outdated Toolset plugins. We always recommend running your site with the latest stable release plugin version.

*** Please make a FULL BACKUP of your database and website.***
Could you please update ALL Toolset plugins to it's latest officially released version. You can download the latest plugin release from your accounts page:

Do you see any difference once you update ALL Toolset plugins to latest version? If no:

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I have set the next reply to private which means only you and I have access to it.


I've update the plugins. The issue persists.

This is staging copy just for you. Go nuts!


Do private messages not show up for me either? I've replied twice privately. I don't see my message and the status still says "This topic contains 2 replies, has 2 voices. Last updated by Minesh 4 hours, 39 minutes ago."

Edit: I opened a new window and now I see my messages. Strange.



Sprachen: Englisch (English )

Zeitzone: Asia/Kolkata (GMT+05:30)

I switched the pagination option to "Pagination enabled with manual transition and page reload" and now I can see the missing post on 2nd page.

To ensure there is no plugin/theme conflict:
*** Please make a FULL BACKUP of your database and website.***
Could you please try to resolve your issue by deactivating all third-party plugins as well as with the default theme to check for any possible conflicts with any of the plugins or themes?
- Do you see any difference?


Perhaps not relevant but FYI:
1. Switched to "Pagination enabled with automatic AJAX transition" as that appears to be the issue. FYI, I will switch to manual on production for now.
2. Turn off all plugins except for Toolset and Oxygen core. Same issue. No change.
3. Turned off Oxygen and went to WP 2021 theme. This gave me the standard WP archive so I created a new page versteckter Link which the view on it. This is even weirder as the page initial loads and shows 21 results (correct) and then some seconds later refreshes (as though there was a change in the form) and then comes back with 20 results (incorrect). If I reload the page and immediately go the page 2 there are 20 results.

Realized that we started with "Pagination enabled with manual transition and AJAX". This works on staging only.
1. This works with all plugins off and the 2021 theme.
2. Turned Oxygen back on. Still works.
3. Turned all plugins back on and it works on the new page as well as versteckter Link
So we just needed to "jiggle the handle"?

I tried the turn all plugins off, switch to 2021 and then back on production and that did not work. I had to restore from backup.

After the restore I switched production to "Pagination enabled with manual transition and AJAX". This shows the Security article on the second page. HOWEVER if i check Prevention > Board it should still show and it does not. This does work on staging now!?

This server is just for you and I to experiment so feel free to turn on/off plugins and switch themes. Thanks!



Sprachen: Englisch (English ) Französisch (Français )

Zeitzone: Africa/Casablanca (GMT+01:00)

Hello there! Minesh is on vacation for a couple of days. If you don't mind, I'll continue with you on this ticket.

I debugged the issue a little bit and I noticed that the post that is missing on the second page is the newly created post "Security and Safety", so I purged the Toolset cache for the view(check this screenshot versteckter Link ) and it fixed the issue for the test page and the resources page.

Can you try from your side on the production site? If it does not work as expected on the production site, please purge SG Optimizer cache too. And it the issue persists, allow me temporary access to check it further. Your next reply will be private to let you share credentials safely.


Jamal, clearing the cache for the view AND SG cache did resolve the immediate issue on production. Unfortunately the issue is still reproducible. This does fix my immediate problem on production though!

If you look at my initial note I did both these steps before ever opening a ticket. Further I believe Minesh also saw the issue the following day. The only thing that I can tell changed is the passage of time.

To test this theory I cloned that same Resource post and renamed it ever so slightly to "Security and Safety II". Then I cleared the cache for the View, then I cleared the SG cache. When versteckter Link is loaded it shows 22 results (correct) going to page 2 shows 21 results (incorrect). The new "Security and Safety II" does not appear in the list. Reloading and starting on page 1 I see 22 results. I then select the Prevention > Board checkbox. This gives 4 results. It should be 5 at this point.

Please investigate further. Thanks!



Sprachen: Englisch (English ) Französisch (Français )

Zeitzone: Africa/Casablanca (GMT+01:00)

It seems that Oxygen Builder has its own caching too. Because if we try on the versteckter Link where Oxygen Builder is not used, we do not encounter any issues. The Toolset cache is invalidated automatically after creating another post.

For the archive page versteckter Link I still encounter the issue. And the only way I can make it work is by:
- Disabling SG Optimizer.
- Cleaning the view cache.
- Saving the Oxygen Builder again. By performing an update, such as removing the view shortcode, saving, then adding it again and saving.
And it is not systematic. Sometimes, I do all the above, and Oxygen Builder still returns cached data instead of the new data(cloned posts).

This can also be because of the fact that you are using a view inside an archive page(Resources custom post type archive page). I would like to suggest the following:
- Create a regular page using Oxygen Builder. And add the view into it. If the issue persists in this case, then Oxygen Builder is, for sure, implementing its own caching for GET and POST requests.
- If the issue is not reproduced on this regular page, we could assume that Oxygen Builder is caching the underlying WP_Query for the archive template.

In both cases, I think that we'll need the Oxygen Builder support team's help here. Please reach to them, and explain that the Toolset view works as expected on a regular page, but does not work as expected in the Oxygen archive template.


Just a nudge to keep this ticket open while I (hopefully) sort things out with Toolset.


Just a nudge to keep this open while working on this with Oxygen.



Sprachen: Englisch (English ) Französisch (Français )

Zeitzone: Africa/Casablanca (GMT+01:00)

Sure. I'll set this ticket as waiting for a reply again, and you will get a similar notification in one week. However, the ticket will be kept open for another week. And you will receive other notifications before it gets closed.

Das Thema „[Geschlossen] New content is not appearing“ ist für neue Antworten geschlossen.