Skip Navigation

[Gelöst] Impossible to assign parent layout

This support ticket is created vor 5 Jahre, 8 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Heute stehen keine Supporter zur Arbeit im Werkzeugsatz-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

Sun Mon Tue Wed Thu Fri Sat
- 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 -
- 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 -

Supporter timezone: Europe/London (GMT+01:00)

Dieses Thema enthält 6 Antworten, hat 3 Stimmen.

Zuletzt aktualisiert von Nigel vor 5 Jahre, 6 Monate.

Assistiert von: Nigel.

unable to assign parent layout.png

I am trying to: Assign a parent layout

Link to a page where the issue can be seen: backend > layouts > edit layout > assign parent layout

I expected to see: the dialog to set a parent layout

Instead, I got: see screenshot

I tried this on two different sites on two different servers and in both cases I got the same result.

I first tried this on a fresh install with the Minimax theme and Toolset Types, Views, Layouts, Forms and Access installed. I created a parent layout with header, footer and a child layout cell. Then I created a layout for pages and tried to set the parent layout to the previously created parent layout. After clicking on the Layout Hierarchy Setting Icon the normal dialog didn't pop up but instead I got the popup in the attached screenshot.

Next I tried it on another site on another server with a site where I first installed the Toolset Starter + child theme and then ran the installer. I installed the same 5 Toolset plugins and also the structure. This also assigns a arent layout and child layouts. I checked this was installed as it is meant to be and it was.
Then I went to edit one of the child layouts (Layout for pages) and went to the parent layout dialog and removed the connection with the parent layout. Next I tried to reinstall the connection with the parent layout, but after clicking the Layout Hierarchy Setting Icon I got the same popup as shown in the attached screenshot.

I tried reverting to Layouts 4.2.2. and Layouts 4.2.1 but the error persists.


I tried the same on the other site (on another server): activated twentyseventeen, went to edit a layout for pages, the icon showed it was set as a child layout and after clicking on it I got the dialog. I changed the parent layoutv to none and saved in the dialog. Then the icon had changed to no parent layout. Clicking on the icon now produces the same error.

Strange thing is that the error also occured with Layouts 2.4.1 installed.


I could not edit my last reply (another bug?).

I wanted to add that the right parent-child relations are instated when installing Toolset Starter (child) and running the installer including the structure. But they get broken after being edited.



Sprachen: Englisch (English ) Spanisch (Español )

Zeitzone: Europe/London (GMT+01:00)

Hi Erik

I've escalated this issue to our second tier (one of whom is an enthusiastic user of hierarchical Layouts with integrated themes, so I expect will look at this promptly).

I'll let you know when I have some feedback.



Sprachen: Englisch (English ) Spanisch (Español )

Zeitzone: Europe/London (GMT+01:00)

Hi Erik

We have an update to Layouts 2.5 imminent, which focuses on WordPress 5.0 compatibility, and will shortly publish an update to 2.5.1 which includes various bug-fixes, including for this issue.

There is a workaround described in this erratum:


Hi Erik,

Nigel is away for a few days and I'm following up on his behalf.

The Layouts 2.5.1 version has been released which addresses the GUI issue that you reported.

Appreciate your report and patience and you're welcome to mark this as resolved, to confirm that the update works.

Feel free to open a new ticket for a different issue or concern - we're here to help.




Sprachen: Englisch (English ) Spanisch (Español )

Zeitzone: Europe/London (GMT+01:00)

Just updating the status here to say the issue should be resolved.

Dieses Ticket ist jetzt geschlossen. Wenn Sie ein Toolset Kunde sind und Hilfe benötigen, eröffnen Sie bitte ein neues Support-Ticket.