Immediately after creating my very first custom post type I began encountering critical errors on my site and cannot access some of the Toolset screens to continue setting up custom fields, etc. I also cannot edit my home page unless I disable the Toolset Types plugin. I'm just getting started and have Toolset Blocks and Toolset Types as my only two plugins at this point.
Here is the error message I received via email:
WordPress version 5.8.1
Current theme: Twenty Twenty-One (version 1.4)
Current plugin: Toolset Types (version 3.4.14)
PHP version 7.4.10
Error Details
=============
An error of type E_ERROR was caused in line 368 of the file /hermes/walnacweb05/walnacweb05an/b887/as.rudyvangelder/wp/wp-content/plugins/types/vendor/toolset/toolset-common/lib/Twig/src/Lexer.php. Error message: Uncaught Error: Call to undefined function ctype_alpha() in /hermes/walnacweb05/walnacweb05an/b887/as.rudyvangelder/wp/wp-content/plugins/types/vendor/toolset/toolset-common/lib/Twig/src/Lexer.php:368
Stack trace:
#0 /hermes/walnacweb05/walnacweb05an/b887/as.rudyvangelder/wp/wp-content/plugins/types/vendor/toolset/toolset-common/lib/Twig/src/Lexer.php(69): OTGS\Toolset\Twig\Lexer->getOperatorRegex()
#1 /hermes/walnacweb05/walnacweb05an/b887/as.rudyvangelder/wp/wp-content/plugins/types/vendor/toolset/toolset-common/lib/Twig/src/Environment.php(610): OTGS\Toolset\Twig\Lexer->__construct(Object(OTGS\Toolset\Twig\Environment))
#2 /hermes/walnacweb05/walnacweb05an/b887/as.rudyvangelder/wp/wp-content/plugins/types/vendor/toolset/toolset-common/lib/Twig/src/Environment.php(695): OTGS\Toolset\Twig\Environment->tokenize(Object(OTGS\Toolset\Twig\Source))
#3 /hermes/walnacweb05/walnacweb05an/b887/as.rudyvangelder/wp/wp-content/plugins/types/vendor/toolset/toolset-common/lib/Twig/src/Environment.php(429): OTGS\Toolset\Tw
versteckter Link
I appreciate any assistance you can provide.
Hi Carl,
Thank you for getting in touch.
Would you mind allowing me to have admin access to the site so that I can have a more detailed look at this one for you ?
I will need to grab a copy of the site as well to test locally.
Thanks,
Shane
Hi Carl,
Not sure what is happening here as it could be server related. When I copied the site I wasn't able to experience any of the issues that you were experiencing. I was able to edit the homepage.
The optional module, imagick, is not installed, or has been disabled.
Could this be a problem?
I'm also noticing this on my copy as well which is an indication that this is not the issue.
Given that this is a fresh site I would recommend that you try to reset and reinstall the website to see if the problem still persists.
For Importing of the site data you can use the plugin below.
https://wordpress.org/plugins/wp-ultimate-csv-importer/
Thanks,
Shane
My issue appears to be resolved now. I needed to enable the ctype.so extension in php.ini file.
Thank you!