Skip Navigation

[Résolu] thumbnail woocommerce doesn't display properly

C'est le forum d'assistance technique pour Toolset : une suite de plugins pour développer des sites WordPress sans écriture PHP.

Tout le monde peut consulter ce forum, mais seuls les clients Toolset peuvent publier des messages dessus. L'assistance Toolset est opérationnelle 6 jours par semaine, 19 heures par jour.

Marqué : ,

This topic contains 9 réponses, has 2 voix.

Last updated by Luo Yang Il y a 4 années et 2 mois.

Assigned support staff: Luo Yang.

Auteur
Publications
#523945

Hello

here is my product page that i built with Types and a template

hidden link

I added ths code to display the main image of the product and thumbnail underneath.
Until the last update of Views it was fine but since, i cannoth see thumbnail but the entire images underneath the image.

[wpv-woo-product-image size='shop_single' output='' enable_third_party_filters='no' gallery_on_listings='yes']

could you help me to display only the thumbnail underneath the main picture?

Thanks

#524094

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

thumbnail.JPG

Dear Silvia,

I just test tested it in your website, I can see the thumbnails underneath the product images. see screenshot thumbnail.JPG. Is this problem resolved?

And you can specific the image size as "thumbnail", for example:
[wpv-woo-product-image size="thumbnail"]

More help:
https://toolset.com/documentation/user-guides/views-shortcodes/#wpv-woo-product-image
size (opt):
'thumbnail' | 'medium' | 'large'' | 'full' | 'shop_single' (default) | 'shop_catalog' | 'shop_thumbnail' | 'custom image size'
The shop_single, shop_catalog and shop_thumbnail sizes can be set in WooCommerce -> Settings -> Catalog -> Image Options

#524107
Capture d’écran 2017-05-15 à 08.54.20.png
_04_—_Commonplaces.png

Hello

the problem is not solved, and on your print screen is not the thumbnail underneath the picture, its the full image resized.
My thumbnails are squared 360x360 and cropped.

I tried this code
[wpv-woo-product-image size='shop_single' output='' enable_third_party_filters='no' gallery_on_listings='yes']
[wpv-woo-product-image size="thumbnail"]

and you can see the result of the two codes on this link hidden link

The first the main image is OK, but the thumbails are not ok
The second the main image is not ok (it s actually the thumbnail enlared)
and underneath is nit the thumbail as expected but the full images...

Could you tell me how to display the main image (large) and underneath the thumbmail (squared and hard cropped images)

Thanks

#524560

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I assume you are going to display the hard-cropped images as the thumbnail of shortcode [wpv-woo-product-image], there isn't such an option within shortcode [wpv-woo-product-image], see our document:
https://toolset.com/documentation/user-guides/views-shortcodes/#wpv-woo-product-image
And I tested itin my localhost, if I disable the "Woocommerce Views plugin", output the product images with Woocommerce plugin built-in templates, I can see it is same result: the thumbnails are the full image resized, can you confirm it?

#524586
1214594-Capture_d_e_cran_2017_02_22_a_13.44.10.png

Hello,

i am sorry to insist, but it was working fine until the last update of VIEWS.

As you can see on a preview screenshot i did a month ago, underneath the main picture there were the hard cropped thumbnails that was displayed.

here its not working > hidden link
on the screenshot > it was working fine, till 4 days ago!!

#524668

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

You are right, it should be able to work.
And the cropping of images is not controlled by WooCommerce Views but by the core WooCommerce plugin.
Please check these in your website:
1) WooCommerce -> Settings -> Products -> Display
Scroll down and you can see the product images section..
There enable the option "Hard crop" for "Single product image" and "Hard crop" for "Product thumbnails"

2) use below shortcode:
[wpv-woo-product-image size='shop_single' output='' enable_third_party_filters='no' gallery_on_listings='no']

3) the best practice after changing thumbnail or image settings is to regenerate thumbnails using this plugin:
https://wordpress.org/plugins/regenerate-thumbnails/
its advised by WC

#524743
Capture d’écran 2017-05-16 à 12.06.59.png

Hello,

1. i put this code in the template :
[wpv-woo-product-image size='shop_single' output='' enable_third_party_filters='no' gallery_on_listings='no']

2. for the size of the thumbnail, please see the attachement (it was already set like this)

3. To be sure i regenarated all the thumbnails with the plugin

>>> but the result is the same.
hidden link

as i said, it should be a problem with the last update of your plugins because before it was fine and now it s not anymore

#525006

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I can not duplicate same problem with the latest version of Woocommerce Views plugin, see the live demo site:
hidden link
we need to know if there is any compatibility problem in your website, please check these:
1) deactivate other plugins and switch to wordpress default theme, and test again
2) Enable PHP debug mode, copy and paste the debug logs here
PHP Debugging
In case you think that Types or Views are doing something wrong (what we call a bug), you should enable PHP error logging. Again, edit your wp-config.php file and add the following:

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');
This will produce a file called ‘error_log.txt’ in your WordPress root directory. Make sure that the web server can create and write this file. If it cannot, use an FTP program to create the file and make it writable to Apache (normally, user www-data).
https://toolset.com/documentation/user-guides/debugging-types-and-views/
3) If the problem persists, please provide a copy of your website, I need to duplicate same problem and debug it in my localhost, thanks:

#527348

Hello,

i need more time to do this, as i am overbooked,
don't close the ticket please.

#527391

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

OK, please update this thread if you need more assistance.

Le forum ‘Assistance professionnelle Toolset’ est fermé à de nouveaux sujets et réponses.