Skip Navigation

[Resuelto] WYSIWYG markup not applied

Este hilo está resuelto. Aquí tiene una descripción del problema y la solución.

HTML markup added to WYSIWYG fields is not applied when rendering the fields in the front end.

Wrap the fields (when inserting as shortcodes) in the wpv-autop shortcode.

Relevant Documentation:

This support ticket is created hace 4 años. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- - 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00
- - - - - - -

Supporter timezone: Asia/Ho_Chi_Minh (GMT+07:00)

This topic contains 4 respuestas, has 2 mensajes.

Last updated by Daniella hace 3 años, 12 meses.

Assisted by: Beda.


For some reason the content in the WYSIWIG custom field is not rendering on my site running the latest Generate Press theme. Don't appear to have any other styling issues, just this.

Please see vid hidden link

Is it a Toolset setting, or do I need to troubleshoot with the theme?



This should be due to the problem mentioned here:

This happens often, please try to use [wpv-autop] shortcodes around the WYSIWYG Field when you output it.



Thanks, that worked. Once the bu is resolve, will [wpv-autop] cause issues? Also, the link you passed along mentioned DIVI. We are not using any page builders ... Toolset Blocks is the page builder 🙂



It could over-p it, yes, if it gets resolved, but I do not think this will happen anytime in the imminent future.
The problem here is that at some point you reach a limit of ability to guess whether or not content should or should not be autop'd

If that erratum gets resolved, I believe it will be because we would deliver a whole new rendering mechanism.

This issue is not due to Divi or only to Divi, it is basically an issue with content rendering in WordPress generally, when the content passes thru several content filters (nested sometimes).


My issue is resolved now. Thank you!

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.