I'm trying to figure out why The Events Calendar is rendering an error on pages where Views are displayed.
Link to a page where the issue can be seen: enlace oculto and enlace oculto
I expected to see: no error at the top
Instead, I got:
Hi Karl,
Thanks for getting in touch.
This is just a warning and not any critical issue. It could be a case where you have your wordpress debugging enabled. Can you checking in you wp-config.php in the root directory of your wordpress install.
Check to ensure that the line with wp_debug is set to false.
Thanks,
Shane
Thanks. That doesn't appear to be the issue. There's no wp_debug in the wp-config file.
It's also happening on other sites as well (enlace oculto), I even added and set wp_debug to false to check 🙁
Hi Karl,
Would you mind allowing me to have admin access to the website so that I can have a more detailed look at this for you ?
Please where applicable please provide me with a link to an example page where I can see the issue.
I've enabled the private fields for your next response.
I may need to grab a copy of your site to test here locally as well.
Thanks,
Shane
Realizing now that the problem isn't limited to where Views are displayed. The error also displays on where custom post types are rendered. See the error on the bottom of enlace oculto
Hi Karl,
I took a copy of the website and deployed it locally here and I wasn't able to replicate the issue.
As you can see from my screenshot the grants page on my copy doesn't display the error.
Given that this issue also occurs on pages where views isn't active then I suspect some issue with the Events Calendar plugin itself.
My recommendation here is perhaps you can cycle through the available php versions on your server as it could be a compatibility issue with your php version or get in touch with the events calendar support team for them to provide you with additional information on this issue.
Thanks,
Shane
Okay, thanks for looking. I'll check in with them to see.
Cheers
Hi Karl,
Thanks once you get an update from them you can let me know if they want anything from our side.
Thanks,
Shane
Got it. I'm following their suggestions here - https://wordpress.org/support/topic/error-regarding-pre_get_posts/
My early suspicion is a conflict between The Events Calendar and Toolset, but I'll confirm in a bit.
So, with most everything (plugins) turned off, the error disappears when I turn off the Blocksy Companion plugin (enlace oculto).
As such, the issue may be the combination of all three (Toolset Views, The Event Calendar and the Blocksy Companion plugin). I've reported this to the team at Blocksy as well.
Hi Karl,
Do you have any other php versions on your server as i'm running version 7.4.12 of php and the issue wasn't present there.
Hopefully The Events Calendar team can provide you with some updates on this given the error is referencing their plugin.
Thanks,
Shane
Hi Shane,
Yes I have a few other versions available. This is running on 7.4.30, but it's been running fine on that version for a long while.
I've added a screenshot of the various versions available.
Hi Karl,
What you can do is to switch to PHP 8 to see if the issue remains as our Toolset plugins are compatible with PHP 8.
If there are any issues you can wait until you get a response from The Events Calendar team.
Thanks,
Shane
Just following up - the team at The Events Calendar confirmed that it's on their end.
https://wordpress.org/support/topic/error-regarding-pre_get_posts/#post-16022118
Thanks again for looking into this.
Karl
Hi Karl,
Thanks for the update. Given they confirmed it on their end you can go ahead and mark this ticket as resolved.
Thanks,
Shane