Skip Navigation

[Resuelto] View ignoring display limit parameter

Este hilo está resuelto. Aquí tiene una descripción del problema y la solución.

Problem:

The nested View is showing ALL the matching terms, despite the fact that the view is set to only show 1 matching result.

Solution:

The problem is abnormal, please check these:

In case it is a compatibility problem, please deactivate all other plugins, and switch to WordPress default theme 2021, deactivate all custom PHP/JS code snippets, and test again

Relevant Documentation:

This support ticket is created hace 1 año, 2 meses. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 4 respuestas, has 3 mensajes.

Last updated by Simon hace 1 año, 2 meses.

Assigned support staff: Luo Yang.

Autor
Mensajes
#2215043

I have a View which loops through terms in a custom taxonomy.

The View output includes another View, into which I am passing the taxonomy title. The idea is to show the most recent WooCommerce product that belongs to each taxonomy term.

However, the nested View is showing ALL the matching terms, despite the fact that the view is set to only show 1 matching result.

Link to a page where the issue can be seen:
hidden link

I expected to see:
1 result per taxonomy term

Instead, I got:
All the matching taxonomy terms are shown

#2215511

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+00:00)

Screenshot 2021-11-08 at 07.54.46.png

Neither of the Views has a limit set, and hence will return all results.

Change the limit option to display only one result if that is the intention.

#2215523

I must have turned off the limit when I was trying to debug the problem

If you look at the nested View:

hidden link

you will now see a limit of 1 is set, and yet the output is ignoring that limit

hidden link

Look forward to your thoughts on that

#2215595

Luo Yang
Supporter

Languages: Inglés (English ) Chino simplificado (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

I have tried it in my localhost with a fresh WP installation + the latest version of Toolset plugins, it works fine, so the problem you mentioned above is abnormal, please check these:
In case it is a compatibility problem, please deactivate all other plugins, and switch to WordPress default theme 2021, deactivate all custom PHP/JS code snippets, and test again

#2215741

Looks like a custom function was overriding the limit set by the View. Thanks.