Skip Navigation

[Enviado al segundo nivel] Shortcodes not rendering in Map Marker pop-up

This support ticket is created hace 3 años, 9 meses. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 8 respuestas, has 3 mensajes.

Last updated by Christian Cox hace 3 años, 8 meses.

Assigned support staff: Christian Cox.

Autor
Mensajes
#1171342
2018-12-21_18-06-43.png

I am trying to:
Add some shortcodes to display contact information in the map marker pop-up

Link to a page where the issue can be seen:
Currently localhost only at the moment (screen grab attached)

I expected to see:
The output in the accordion above was generated using the same shortcodes as I have used in the creation of the map marker pop-up

Instead, I got:
The shortcodes are not rendering, they just output as text

Below is the code which I am using on my Beaver Themer Single Template:-

[wpv-map-render map_id="map-single-home" map_height="450px" single_zoom="15" draggable="off" scrollwheel="off" double_click_zoom="off" map_type_control="off" background_color="#436176"]
<h3 class="map-preload-text">Please wait while the map is loading…</h3>
[/wpv-map-render][wpv-map-marker map_id='map-single-home' marker_id='marker-1' marker_title='click to view details' marker_field='wpcf-location']<strong>[wpv-post-title]</strong><br />
[types field='location'][/types]<br /><br />

Home Manager: [wpv-post-field name='home_manager']<br />
T: [wpv-post-field name='telephone']<br />
[/wpv-map-marker]
#1172055

Hi, I'm able to replicate this problem on a local test site. I'm going to escalate this to my 2nd tier support team for additional investigation. We may have a minor compatibility issue here with Beaver Themer. I'll let you know what I find out.

#1172059

Hi Christian,

Thank you for the update. I'm glad it wasn't just me.
I look forward to hearing back from you once 2nd Tier support have taken a look.
Have a great Christmas.

Kind regards,
Craig

#1172704

Hi,

As Christian is off, I'm posting here to notify you that this issue has been escalated to the development team.
They will fix it ASAP.

Here is an errata page that describes the situation: https://toolset.com/errata/shortcodes-inside-the-map-marker-pop-up-are-not-executed-in-beaver-themer-templates/

Please keep watching this ticket and we will notify you once we get any updates.

Thanks.

#1175150

Hi Mohammed,

Many thanks for getting back to me on this matter in Christian's absence.

You may, or may not, be able to answer this, but is there a proposed eta for the fix on this issue? I am asking because if it is going to be quite a while, I will need to look into an alternative solution.

Kind regards,
Craig

#1175199

Hi, I don't have a solid timeline available yet but based on the current holiday schedule I suspect a fix will not be available this week. Beyond that, I can't say for sure. I'll try to get some more concrete information and give you an update.

#1175366

Thank you Christian… and Happy New Year!

#1192098

Hi Christian,

Just wondered if there was any further information available yet on the issue of shortcodes not rendering in Map Marker pop-up?

Kind regards,
Craig

#1192174

Unfortunately there's nothing new to share at this time. I will keep you posted here as I receive more information.