Skip Navigation

[Resuelto] Content not saved in WYSIWYG field

Este hilo está resuelto. Aquí tiene una descripción del problema y la solución.

Problem:
The content of WYSIWYG fields are lost upon saving.

Solution:
This is a bug that was introduced by WP 5.8 and fixed in WP 5.8.1.

This support ticket is created hace 1 año, 4 meses. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 - - 9:00 – 13:00
14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 - - 14:00 – 18:00

Supporter timezone: Africa/Casablanca (GMT+01:00)

This topic contains 2 respuestas, has 2 mensajes.

Last updated by Simon hace 1 año, 4 meses.

Assigned support staff: Jamal.

Autor
Mensajes
#2181725

I am trying to: Save contents in a WYSIWYG field on a custom post type

Link to a page where the issue can be seen: hidden link (password protected post, password is 'toolset')

I expected to see: Contents of WYSIWYG field displayed below 'Recommended on' date

Instead, I got:
When I enter my text in the field in Visual mode and Publish the post, the text is missing when the editor interface reloads. If I enter in Text mode and Publish / Update the content is not lost. If I enter in Text mode and switch to Visual mode, the content stays in place.

I have tried:
- Disabling all plugins except Types and Blocks
- Switching to a standard WP theme

These didn't change the behaviour. This looks like an out-and-out bug to me.

#2181819

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting Toolset support.

Our developers are aware of issues that appeared on WYSIWYG editors after WP 5.8. We fixed a bug in Types 3.4.14, but we are still working on some cases. This bug appears for post types that do not activate the Editor option. As a workaround, please enable it on the post type and let us know if it fixes the issue. Check this screenshot hidden link

If that does not help, we'll need to take a copy of your website and give it to the developers for further analysis. Let us know if that would be fine with you!

#2181855

That does resolve the issue, although I will have to make sure the client knows we're not using the Editor for anything!